<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>mongoDB vs. MySQL | Database Journal</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700%7CVarela%3A400%2C700%7CRoboto%3A900%2C400%7CMontserrat%3A400%2C500%2C600%7COpen%20Sans%3A500%2C400&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700%7CVarela%3A400%2C700%7CRoboto%3A900%2C400%7CMontserrat%3A400%2C500%2C600%7COpen%20Sans%3A500%2C400&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700%7CVarela%3A400%2C700%7CRoboto%3A900%2C400%7CMontserrat%3A400%2C500%2C600%7COpen%20Sans%3A500%2C400&#038;display=swap" /></noscript>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.databasejournal.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="icon" type="image/png" href="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_Favicon.png">
	<!-- This site is optimized with the Yoast SEO plugin v19.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="MongoDB and MySQL are top-ranked databases. But how do they compare? Read our database comparison and feature review." />
	<link rel="canonical" href="https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="mongoDB vs. MySQL | Database Journal" />
	<meta property="og:description" content="MongoDB and MySQL are top-ranked databases. But how do they compare? Read our database comparison and feature review." />
	<meta property="og:url" content="https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/" />
	<meta property="og:site_name" content="Database Journal" />
	<meta property="article:published_time" content="2022-07-07T21:45:41+00:00" />
	<meta property="article:modified_time" content="2022-07-07T21:46:23+00:00" />
	<meta property="og:image" content="https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb.jpg" />
	<meta property="og:image:width" content="2400" />
	<meta property="og:image:height" content="1500" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="David Manda" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="David Manda" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="9 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.databasejournal.com/#organization","name":"Database Journal","url":"https://www.databasejournal.com/","sameAs":[],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.databasejournal.com/#/schema/logo/image/","url":"https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_MainLogo-copy-2.png","contentUrl":"https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_MainLogo-copy-2.png","width":1134,"height":170,"caption":"Database Journal"},"image":{"@id":"https://www.databasejournal.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://www.databasejournal.com/#website","url":"https://www.databasejournal.com/","name":"Database Journal","description":"","publisher":{"@id":"https://www.databasejournal.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.databasejournal.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/#primaryimage","url":"https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb.jpg","contentUrl":"https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb.jpg","width":2400,"height":1500,"caption":"MongoDB tutorials"},{"@type":"WebPage","@id":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/#webpage","url":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/","name":"mongoDB vs. MySQL | Database Journal","isPartOf":{"@id":"https://www.databasejournal.com/#website"},"primaryImageOfPage":{"@id":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/#primaryimage"},"datePublished":"2022-07-07T21:45:41+00:00","dateModified":"2022-07-07T21:46:23+00:00","description":"MongoDB and MySQL are top-ranked databases. But how do they compare? Read our database comparison and feature review.","breadcrumb":{"@id":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/"]}]},{"@type":"BreadcrumbList","@id":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.databasejournal.com/"},{"@type":"ListItem","position":2,"name":"mongoDB vs. MySQL"}]},{"@type":"Article","@id":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/#article","isPartOf":{"@id":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/#webpage"},"author":{"name":"David Manda","@id":"https://www.databasejournal.com/#/schema/person/f844e26a92742052f81ad5e4f348cc9e"},"headline":"mongoDB vs. MySQL","datePublished":"2022-07-07T21:45:41+00:00","dateModified":"2022-07-07T21:46:23+00:00","mainEntityOfPage":{"@id":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/#webpage"},"wordCount":1885,"publisher":{"@id":"https://www.databasejournal.com/#organization"},"image":{"@id":"https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/#primaryimage"},"thumbnailUrl":"https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb.jpg","keywords":["database","MongoDB","MySQL","RDBMS","relational database"],"articleSection":["MySQL"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.databasejournal.com/#/schema/person/f844e26a92742052f81ad5e4f348cc9e","name":"David Manda","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.databasejournal.com/#/schema/person/image/","url":"https://www.databasejournal.com/wp-content/uploads/2022/04/IMG-20190728-WA0062-David-Manda-e1649447470595-150x150.jpg","contentUrl":"https://www.databasejournal.com/wp-content/uploads/2022/04/IMG-20190728-WA0062-David-Manda-e1649447470595-150x150.jpg","caption":"David Manda"},"description":"David Manda is a contributing writer for Database Journal. His background is in education, technology, and digital marketing.","url":"https://www.databasejournal.com/author/david-manda/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//adservice.google.com' />
<link rel='dns-prefetch' href='//cs.emxdgt.com' />
<link rel='dns-prefetch' href='//dpm.demdex.net' />
<link rel='dns-prefetch' href='//e.servebid.com' />
<link rel='dns-prefetch' href='//eb2.3lift.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//googletagservices.com' />
<link rel='dns-prefetch' href='//p.typekit.net' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//match.adsrvr.org' />
<link rel='dns-prefetch' href='//e.serverbid.com' />
<link rel='dns-prefetch' href='//jadserve.postrelease.com' />
<link rel='dns-prefetch' href='//match.sharethrough.com' />
<link rel='dns-prefetch' href='//securepubads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//sync.1rx.io' />
<link rel='dns-prefetch' href='//usermatch.targeting.unrulymedia.com' />
<link rel='dns-prefetch' href='//prebid-match.dotomi.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Database Journal &raquo; Feed" href="https://www.databasejournal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Database Journal &raquo; Comments Feed" href="https://www.databasejournal.com/comments/feed/" />
<!-- databasejournal.com is managing ads with Advanced Ads 1.34.0 – https://wpadvancedads.com/ --><!--noptimize--><script id="wp-ads-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<!--/noptimize--><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.databasejournal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link data-minify="1" rel='stylesheet' id='ppress-frontend-css'  href='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=1652717030' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css'  href='https://www.databasejournal.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.15' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-select2-css'  href='https://www.databasejournal.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=5.9.3' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='parent-style-css'  href='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/themes/Newspaper/style.css?ver=1652717030' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=1652717030' type='text/css' media='all' />

<link data-minify="1" rel='stylesheet' id='tablepress-default-css'  href='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/tablepress/css/default.min.css?ver=1652717030' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='font_awesome-css'  href='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/td-composer/assets/fonts/font-awesome/font-awesome.css?ver=1652717030' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='td-theme-css'  href='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/themes/src/style.css?ver=1652717030' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link data-minify="1" rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=1652717031' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=1652717031' type='text/css' media='all' />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player:focus-within{outline: 2px solid currentColor;outline-offset: 5px;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:100%;width:100%;left:0;top:0;position:absolute;background:url(https://www.databasejournal.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat center;background-color: transparent !important;cursor:pointer;border:none;}
</style>
<script type='text/javascript' src='https://www.databasejournal.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=5.9.3' id='ppress-flatpickr-js' defer></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=5.9.3' id='ppress-select2-js' defer></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.34.0' id='advanced-ads-advanced-js-js' defer></script>
<script type='text/javascript' id='advanced_ads_pro/visitor_conditions-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js?ver=2.17.2' id='advanced_ads_pro/visitor_conditions-js' defer></script>

<!-- Google Analytics snippet added by Site Kit -->
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-48210401-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.databasejournal.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-48210401-1", {"anonymize_ip":true});
gtag("config", "G-L8L55SKXS5");
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<link rel="https://api.w.org/" href="https://www.databasejournal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.databasejournal.com/wp-json/wp/v2/posts/16679" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.databasejournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.databasejournal.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.databasejournal.com/?p=16679' />
<link rel="alternate" type="application/json+oembed" href="https://www.databasejournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.databasejournal.com%2Fmysql%2Fmongodb-vs-mysql-database-journal%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.databasejournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.databasejournal.com%2Fmysql%2Fmongodb-vs-mysql-database-journal%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.78.0" /><script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="wp-ads-layer-custom-css"></style>
<link rel="preload" as="font" href="https://www.databasejournal.com/wp-content/plugins/td-composer/assets/fonts/font-awesome/fontawesome-webfont.woff2" crossorigin>
<link rel="preload" as="font" href="https://www.databasejournal.com/wp-content/themes/Newspaper/images/icons/newspaper.woff" crossorigin><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"8d56e07da0","wpRestUrl":"https:\/\/www.databasejournal.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","globalSettings":{"tdcSavingHistory":false},"isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    
    <style id="tdb-global-colors">
        :root {--accent-color: #fff;}
    </style>
	
			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.databasejournal.com\/wp-admin\/","wpRestNonce":"8d56e07da0","wpRestUrl":"https:\/\/www.databasejournal.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
			</script>
			    <script>
        window.tdaGlobal = {"adminUrl":"https:\/\/www.databasejournal.com\/wp-admin\/","wpRestNonce":"8d56e07da0","wpRestUrl":"https:\/\/www.databasejournal.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","postId":138};
    </script>
    
<!-- Google Tag Manager snippet added by Site Kit -->
<script type="text/javascript">
			( function( w, d, s, l, i ) {
				w[l] = w[l] || [];
				w[l].push( {'gtm.start': new Date().getTime(), event: 'gtm.js'} );
				var f = d.getElementsByTagName( s )[0],
					j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
				j.async = true;
				j.src = 'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
				f.parentNode.insertBefore( j, f );
			} )( window, document, 'script', 'dataLayer', 'GTM-PSKJD7X' );
			
</script>

<!-- End Google Tag Manager snippet added by Site Kit -->

<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Start: GAM Head Tag -->

<!-- Start: Data Layer -->
<script>
    // Setup our base data layer

    window.dataLayer = window.dataLayer || [];
    dataLayer.push(
        {"event":"CMS_Data","taxonomy":["product development architecture modeling","product applications business intelligence analytics big data analytics","product development client side","product development cloud","product development components libraries","product applications business intelligence data analytics","product servers database data import export","product it database data management","product servers database data manipulation","product applications business intelligence analytics data mining","product servers database","product staffing training certifications events training certifications database management training certifications","product servers database reporting services","product development","product development tools","product development distributed","product development embedded","audience purchase stage evaluation","product development embedded internet of things","product development interoperability","product servers database legacy system integration","product development mobile","product development multiexperience development","product development open source software development","product development platform framework","product development programming languages","product development security","product development server side","product development services web or platform","product development methodologies softwaredevelopmentlifecycle sdl","product servers database stored procedures","industry technology","product development testing debugging qa","product servers database vendor specific databases","product web internet development"],"category":"mysql","keywords":["database","mongodb","mysql","rdbms","relational-database"]}    );
</script>
<!-- End: Data Layer-->
<!-- End: GAM Head Tag -->

<!-- Start: Advertising Core -->
<script data-minify="1" src="https://www.databasejournal.com/wp-content/cache/min/1/tag/js/gpt.js?ver=1652717031" async></script>

<script>window.googletag=window.googletag||{cmd:[]},window.ta=window.ta||{gam:{ready:!1,tags:{}}};var mbw=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;getDataLayerValue=function(e,t,a){for(var o=0,n=window.dataLayer.length;o<n;o++){var g;if(void 0!==dataLayer[o][e]&&(g=t?cleanKeyValue_GAM(dataLayer[o][e]):dataLayer[o][e],a))return g}return g},getURLSegments=function(e){return e.split("/").filter(function(e){return null!=e&&""!=e&&null!=e})},getCMSEnvironment=function(){var e=new RegExp(/(local|dev)\.wordpress\.relay\.cool/).test(window.location.hostname),t=new RegExp(/.*(local|dev).*\.wpengine\.com/).test(window.location.hostname),a=new RegExp(/stage\.wordpress\.relay\.cool/).test(window.location.hostname),o=new RegExp(/.*(stage|stg|esplanetst).*\.wpengine\.com/).test(window.location.hostname);return e||t?"dev":a||o?"stage":"prod"},getGAMCookie=function(e){for(var t=e+"=",a=document.cookie.split(";"),o=0;o<a.length;o++){var n=a[o].replace(/^\s+|\s+$/g,"");if(0==n.indexOf(t))return n.substring(t.length,n.length)}return""},setGAMCookie=function(e,t,a,o){if(!(e&&t&&a&&o))return!1;var n=new Date;switch(o){case"mo":n.setMonth(n.getMonth()+a);break;case"hr":n.setTime(n.getTime()+60*a*60*1e3);break;case"min":n.setTime(n.getTime()+60*a*1e3);break;case"sec":n.setTime(n.getTime()+1e3*a);break;default:n.setTime(n.getTime()+24*a*60*60*1e3)}var g="expires="+n.toUTCString();document.cookie=e+"="+t+";"+g+";path=/"},checkGAMCookie=function(e){return e&&""!=getGAMCookie(e)?1:0},cleanKeyValue_GAM=function(e){if(e)if(Array.isArray(e))for(i=0;i<e.length;i++)e[i]=e[i].replace(/["'=!+#*~;^()<>\[\],&]/g,"").replace(/\s+/g," ").replace(/^\s+|\s+$/g,"");else"object"==typeof e&&null!==e?Object.keys(e).forEach(function(t){e[t]=e[t].replace(/["'=!+#*~;^()<>\[\],&]/g,"").replace(/\s+/g," ").replace(/^\s+|\s+$/g,"")}):e=e.replace(/["'=!+#*~;^()<>\[\],&]/g,"").replace(/\s+/g," ").replace(/^\s+|\s+$/g,"");return e},dumpGAMTargeting=function(){if(window.googletag&&googletag.pubadsReady){var e=window.googletag.pubads().getTargetingKeys();for(k=0;k<e.length;k++)console.log(e[k],googletag.pubads().getTargeting(e[k]))}},refreshDFPTags=function(){if(window.googletag&&googletag.pubadsReady)for(var e in window.ta.gam.tags)window.ta.gam.tags.hasOwnProperty(e)&&null!=window.ta.gam.tags[e]&&void 0!==window.ta.gam.tags[e].slot&&window.ta.gam.tags[e].refreshable&&(window.ta.gam.tags[e].refreshed=!0,window.ta.gam.tags[e].refresh_counter++,googletag.pubads().refresh([window.ta.gam.tags[e].slot],{changeCorrelator:!1}))},hide__div=function(e){if(e){if(window.googletag&&googletag.pubadsReady){var t=e.replace(/-outer/,"").replace(/-/g,"");void 0!==window.ta.gam.tags[t].slot&&(googletag.destroySlots([window.ta.gam.tags[t].slot]),window.ta.gam.tags[t]=null)}document.getElementById&&(document.getElementById(e).style.visibility="hidden",document.getElementById(e).innerHTML="")}};</script>
<script>googletag.cmd.push(function(){var _env=getCMSEnvironment(),_clean_path=cleanKeyValue_GAM(getURLSegments(window.location.pathname)),_clean_kw=cleanKeyValue_GAM(["database","mongodb","mysql","rdbms","relational-database"]),_clean_tax=cleanKeyValue_GAM(["product development architecture modeling","product applications business intelligence analytics big data analytics","product development client side","product development cloud","product development components libraries","product applications business intelligence data analytics","product servers database data import export","product it database data management","product servers database data manipulation","product applications business intelligence analytics data mining","product servers database","product staffing training certifications events training certifications database management training certifications","product servers database reporting services","product development","product development tools","product development distributed","product development embedded","audience purchase stage evaluation","product development embedded internet of things","product development interoperability","product servers database legacy system integration","product development mobile","product development multiexperience development","product development open source software development","product development platform framework","product development programming languages","product development security","product development server side","product development services web or platform","product development methodologies softwaredevelopmentlifecycle sdl","product servers database stored procedures","industry technology","product development testing debugging qa","product servers database vendor specific databases","product web internet development"]),_clean_category=cleanKeyValue_GAM("mysql"),_clean_mlt=cleanKeyValue_GAM(getGAMCookie("mlt")),_clean_mlcr=cleanKeyValue_GAM(getGAMCookie("mlcr")),_clean_mlcs=cleanKeyValue_GAM(getGAMCookie("mlcs")),_clean_mldm=cleanKeyValue_GAM(getGAMCookie("mldm")),_clean_mlsr=cleanKeyValue_GAM(getGAMCookie("mlsr")),_clean_mlpc=cleanKeyValue_GAM(getGAMCookie("mlpc")),_clean_mldcm=cleanKeyValue_GAM(getGAMCookie("mldcm")),_clean_mlfa=cleanKeyValue_GAM(getGAMCookie("mlfa")),_clean_mlins=cleanKeyValue_GAM(getGAMCookie("mlins")),_clean_mlpg=cleanKeyValue_GAM(getGAMCookie("mlpg")),_clean_mledu=cleanKeyValue_GAM(getGAMCookie("mledu")),_clean_mlind=cleanKeyValue_GAM(getGAMCookie("mlind"));_clean_mlt&&googletag.pubads().setTargeting("mlt",_clean_mlt),_clean_mlcr&&googletag.pubads().setTargeting("mlcr",_clean_mlcr),_clean_mlcs&&googletag.pubads().setTargeting("mlcs",_clean_mlcs),_clean_mldm&&googletag.pubads().setTargeting("mldm",_clean_mldm),_clean_mlsr&&googletag.pubads().setTargeting("mlsr",_clean_mlsr),_clean_mlpc&&googletag.pubads().setTargeting("mlpc",_clean_mlpc),_clean_mldm&&googletag.pubads().setTargeting("mldcm",_clean_mldcm),_clean_mlfa&&googletag.pubads().setTargeting("mlfa",_clean_mlfa),_clean_mlins&&googletag.pubads().setTargeting("mlins",_clean_mlins),_clean_mlpg&&googletag.pubads().setTargeting("mlpg",_clean_mlpg),_clean_mledu&&googletag.pubads().setTargeting("mledu",_clean_mledu),_clean_mlind&&googletag.pubads().setTargeting("mlind",_clean_mlind),googletag.pubads().setTargeting("env",_env),googletag.pubads().setTargeting("url",window.location.hostname.concat(window.location.pathname)),googletag.pubads().setTargeting("hostname",window.location.hostname),googletag.pubads().setTargeting("kw",_clean_kw),googletag.pubads().setTargeting("tax",_clean_tax),googletag.pubads().setTargeting("category",_clean_category),googletag.pubads().setTargeting("path",_clean_path),googletag.pubads().enableSingleRequest(),googletag.enableServices();});</script>
<!-- End: Advertising Core --><!-- Start: GAM Ad Slot Definitions | DBJ MySQL Page -->
<script>
    window.googletag = window.googletag ||
    {
        cmd: []
    };
    
    window.ta = window.ta ||
    {
        gam:
        {
            ready: false,
            tags:
            {}
        }
    };
    
    googletag.cmd.push(function()
    {

        // Define Ad Slot Configurations

        // Inline Top
        window.ta.gam.tags.inlinetop = {
            id: 'inline-top',
            refreshable: true,
            refresh_delay: 5,
            pending_refresh: false,
            refreshed: false,
            max_refresh: 5,
            refresh_counter: 0,
            viewable: false,
            in_view: undefined,
            visibility: 0,
            view_percentage_threshold: 85
        };

        window.ta.gam.tags.inlinetop.slot =
			googletag.defineSlot(
            '/5055/B2B/IT/databasejournal/mysql/inline-top',
            [
                [300,50],[320,50],[728,90],[970,90],[970,250],[1000,90]],'inline-top').defineSizeMapping(
                    googletag.sizeMapping()

                    // Desktop
                    .addSize([1240,650],
                        [[728,90],[970,90],[970,250],[1000,90]])

                    // Tablet
                    .addSize([768,321],
                        [[728,90]])

                    // Mobile
                    .addSize([0,0],
                        [[300,50],[320,50]])

                    .build())
                    .addService(googletag.pubads())
                    .setTargeting('pos','top')
                    .setTargeting('refreshable','true')
                    .setTargeting('adrefreshed','false');

        // Sticky Rail
        window.ta.gam.tags.stickyrail = {
            id: 'sticky-rail',
            refreshable: true,
            refresh_delay: 5,
            pending_refresh: false,
            refreshed: false,
            max_refresh: 5,
            refresh_counter: 0,
            viewable: false,
            in_view: undefined,
            visibility: 0,
            view_percentage_threshold: 85
        };

        window.ta.gam.tags.stickyrail.slot = googletag.defineSlot(
            '/5055/B2B/IT/databasejournal/mysql/sticky-rail',
            [
                [300,50],[320,50],[300,250],[300,600],[160,600]],'sticky-rail').defineSizeMapping(
                    googletag.sizeMapping()

                    // Desktop
                    .addSize([1240,650],
                        [[300,250],[300,600],[160,600]])

                    // Tablet
                    .addSize([768,650],
                        [[300,250],[300,600],[160,600]])

                    // Mobile
                    .addSize([0,0],
                        [[300,50],[320,50],[300,250]])

                    .build())
                    .addService(googletag.pubads())
                    .setTargeting('pos','top')
                    .setTargeting('refreshable','true')
                    .setTargeting('adrefreshed','false');

        // Sticky Bottom
        window.ta.gam.tags.stickybottom = {
            id: 'sticky-bottom',
            refreshable: true,
            refresh_delay: 5,
            pending_refresh: false,
            refreshed: false,
            max_refresh: 5,
            refresh_counter: 0,
            viewable: false,
            in_view: undefined,
            visibility: 0,
            view_percentage_threshold: 85
        };

        window.ta.gam.tags.stickybottom.slot =
			googletag.defineSlot(
            '/5055/B2B/IT/databasejournal/mysql/sticky-bottom',
            [
                [300,50],[320,50],[728,90],[970,90],[1000,90]],'sticky-bottom').defineSizeMapping(
                    googletag.sizeMapping()

                    // Desktop
                    .addSize([1240,650],
                        [[728,90],[970,90],[1000,90]])

                    // Tablet
                    .addSize([768,321],
                        [[728,90]])

                    // Mobile
                    .addSize([0,0],
                        [[300,50],[320,50]])

                    .build())
                    .addService(googletag.pubads())
                    .setTargeting('pos','sticky')
                    .setTargeting('refreshable','true')
                    .setTargeting('adrefreshed','false');

    });
</script>
<!-- End: GAM Ad Slot Definitions | DBJ MySQL Page -->
<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                body .tdm-social-item i {
                    color: #67bb51;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #67bb51;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #67bb51;
                }
                .tdm-btn-style1 {
					background-color: #67bb51;
				}
				.tdm-btn-style2:before {
				    border-color: #67bb51;
				}
				.tdm-btn-style2 {
				    color: #67bb51;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #67bb51;
                    -moz-box-shadow: 0 2px 16px #67bb51;
                    box-shadow: 0 2px 16px #67bb51;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #67bb51;
                    -moz-box-shadow: 0 4px 26px #67bb51;
                    box-shadow: 0 4px 26px #67bb51;
				}
</style>

	<style id="tdw-css-placeholder"></style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>

<body class="post-template-default single single-post postid-16679 single-format-standard td-standard-pack mongodb-vs-mysql-database-journal global-block-template-2 tdb_template_138 aa-prefix-wp-ads- tdb-template  tdc-header-template  tdc-footer-template td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

            <div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background" style="visibility:hidden"></div>
<div id="td-mobile-nav" style="visibility:hidden">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-header-menu-container"><ul id="menu-header-menu" class="td-mobile-main-menu"><li id="menu-item-16005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-16005"><a href="https://www.databasejournal.com/database-news/">Database News</a></li>
<li id="menu-item-16007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16007"><a href="https://www.databasejournal.com/features/">Features</a></li>
<li id="menu-item-16015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16015"><a href="https://www.databasejournal.com/scripts/">Scripts</a></li>
<li id="menu-item-16010" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16010"><a href="https://www.databasejournal.com/mysql/">MySQL</a></li>
<li id="menu-item-16009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16009"><a href="https://www.databasejournal.com/ms-sql/">MS SQL</a></li>
<li id="menu-item-16011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16011"><a href="https://www.databasejournal.com/oracle/">Oracle</a></li>
<li id="menu-item-16008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16008"><a href="https://www.databasejournal.com/ms-access/">MS Access</a></li>
<li id="menu-item-16006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16006"><a href="https://www.databasejournal.com/db2/">DB2</a></li>
<li id="menu-item-16013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16013"><a href="https://www.databasejournal.com/postgresql/">PostgreSQL</a></li>
<li id="menu-item-16014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16014"><a href="https://www.databasejournal.com/sap/">SAP</a></li>
<li id="menu-item-16012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16012"><a href="https://www.databasejournal.com/php/">PHP</a></li>
<li id="menu-item-16618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16618"><a href="https://forums.databasejournal.com/">Forums</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background" style="visibility:hidden"></div>
<div class="td-search-wrap-mob" style="visibility:hidden">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.databasejournal.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
                    <div class="td-header-template-wrap" style="position: relative">
                                    <div class="td-header-mobile-wrap ">
                        <div id="tdi_1" class="tdc-zone"><div class="tdc_zone tdi_2  wpb_row td-pb-row tdc-element-style"  >
<style scoped>

/* custom css */
.tdi_2{
                    min-height: 0;
                }.td-header-mobile-wrap{
                    position: relative;
                    width: 100%;
                }

/* phone */
@media (max-width: 767px){
.tdi_2:before{
                    content: '';
                    display: block;
                    width: 100vw;
                    height: 100%;
                    position: absolute;
                    left: 50%;
                    transform: translateX(-50%);
                    box-shadow:  0px 6px 8px 0px rgba(0, 0, 0, 0.08);
                    z-index: 20;
                    pointer-events: none;
                }@media (max-width: 767px) {
                    .tdi_2:before {
                        width: 100%;
                    }
                }
}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_2{
position:relative;
}
}

</style>
<div class="tdi_1_rand_style td-element-style" ><style>
/* phone */
@media (max-width: 767px)
{
.tdi_1_rand_style{
background-color:#222222 !important;
}
}
 </style></div><div id="tdi_3" class="tdc-row"><div class="vc_row tdi_4  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_4,
                .tdi_4 .tdc-columns{
                    min-height: 0;
                }.tdi_4,
				.tdi_4 .tdc-columns{
				    display: block;
				}.tdi_4 .tdc-columns{
				    width: 100%;
				}

/* phone */
@media (max-width: 767px){
@media (min-width: 768px) {
	                .tdi_4 {
	                    margin-left: -0px;
	                    margin-right: -0px;
	                }
	                .tdi_4 .tdc-row-video-background-error,
	                .tdi_4 .vc_column {
	                    padding-left: 0px;
	                    padding-right: 0px;
	                }
                }
}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_4{
position:relative;
}
}

</style>
<div class="tdi_3_rand_style td-element-style" ><style>
/* phone */
@media (max-width: 767px)
{
.tdi_3_rand_style{
background-color:#ffffff !important;
}
}
 </style></div><div class="vc_column tdi_6  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>

/* custom css */
.tdi_6{
                    vertical-align: baseline;
                }.tdi_6 > .wpb_wrapper,
				.tdi_6 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_6 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_6 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_6 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_6{
                    vertical-align: middle;
                }
}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_6{
width:20% !important;
display:inline-block !important;
}
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_menu tdi_7 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_7" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_7{
margin-left:-13px !important;
}
}

</style>
<style>
/* custom css */
.tdb-header-align{
                  vertical-align: middle;
                }.tdb_mobile_menu{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_mobile_menu a{
                  display: inline-block !important;
                  position: relative;
                  text-align: center;
                  color: #4db2ec;
                }.tdb_mobile_menu a > span{
                  display: flex;
                  align-items: center;
                  justify-content: center;
                }.tdb_mobile_menu svg{
                  height: auto;
                }.tdb_mobile_menu svg,
                .tdb_mobile_menu svg *{
                  fill: #4db2ec;
                }#tdc-live-iframe .tdb_mobile_menu a{
                  pointer-events: none;
                }.tdi_7{
                    display: inline-block;
                }.tdi_7 .tdb-mobile-menu-button i{
                    font-size: 22px;
                
                    width: 55px;
					height: 55px;
					line-height:  55px;
                }.tdi_7 .tdb-mobile-menu-button svg{
                    width: 22px;
                }.tdi_7 .tdb-mobile-menu-button .tdb-mobile-menu-icon-svg{
                    width: 55px;
					height: 55px;
                }.tdi_7 .tdb-mobile-menu-button{
                    color: #1c3552;
                }.tdi_7 .tdb-mobile-menu-button svg,
                .tdi_7 .tdb-mobile-menu-button svg *{
                    fill: #1c3552;
                }.tdi_7 .tdb-mobile-menu-button:hover{
                    color: #67bb51;
                }.tdi_7 .tdb-mobile-menu-button:hover svg,
                .tdi_7 .tdb-mobile-menu-button:hover svg *{
                    fill: #67bb51;
                }

/* phone */
@media (max-width: 767px){
.tdi_7 .tdb-mobile-menu-button i{
                    font-size: 27px;
                
                    width: 54px;
					height: 54px;
					line-height:  54px;
                }.tdi_7 .tdb-mobile-menu-button svg{
                    width: 27px;
                }.tdi_7 .tdb-mobile-menu-button .tdb-mobile-menu-icon-svg{
                    width: 54px;
					height: 54px;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-mobile-menu-button" aria-label="menu-button" href="#"><i class="tdb-mobile-menu-icon td-icon-mobile"></i></a></div></div> <!-- ./block --></div></div><div class="vc_column tdi_9  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>

/* custom css */
.tdi_9{
                    vertical-align: baseline;
                }.tdi_9 > .wpb_wrapper,
				.tdi_9 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_9 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_9 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_9 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_9{
                    vertical-align: middle;
                }
}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_9{
width:60% !important;
display:inline-block !important;
}
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_10 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_10" >
<style>
/* custom css */
.tdb_header_logo{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_header_logo .tdb-logo-a,
                .tdb_header_logo h1{
                  display: flex;
                  pointer-events: auto;
                  align-items: flex-start;
                }.tdb_header_logo h1{
                  margin: 0;
                  line-height: 0;
                }.tdb_header_logo .tdb-logo-img-wrap img{
                  display: block;
                }.tdb_header_logo .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                  display: none;
                }.tdb_header_logo .tdb-logo-svg-wrap svg{
                  width: 50px;
                  display: block;
                  transition: fill .3s ease;
                }.tdb_header_logo .tdb-logo-text-wrap{
                  display: flex;
                }.tdb_header_logo .tdb-logo-text-title,
                .tdb_header_logo .tdb-logo-text-tagline{
                  -webkit-transition: all 0.2s ease;
                  transition: all 0.2s ease;
                }.tdb_header_logo .tdb-logo-text-title{
                  background-size: cover;
                  background-position: center center;
                  font-size: 75px;
                  font-family: serif;
                  line-height: 1.1;
                  color: #222;
                  white-space: nowrap;
                }.tdb_header_logo .tdb-logo-text-tagline{
                  margin-top: 2px;
                  font-size: 12px;
                  font-family: serif;
                  letter-spacing: 1.8px;
                  line-height: 1;
                  color: #767676;
                }.tdb_header_logo .tdb-logo-icon{
                  position: relative;
                  font-size: 46px;
                  color: #000;
                }.tdb_header_logo .tdb-logo-icon-svg{
                  line-height: 0;
                }.tdb_header_logo .tdb-logo-icon-svg svg{
                  width: 46px;
                  height: auto;
                }.tdb_header_logo .tdb-logo-icon-svg svg,
                .tdb_header_logo .tdb-logo-icon-svg svg *{
                  fill: #000;
                }.tdi_10 .tdb-logo-a,
                .tdi_10 h1{
                    flex-direction: row;
                
                    align-items: center;
                
                    justify-content: center;
                }.tdi_10 .tdb-logo-svg-wrap{
                    display: block;
                }.tdi_10 .tdb-logo-img-wrap{
                    display: none;
                }.tdi_10 .tdb-logo-text-tagline{
                    margin-top: -3px;
                    margin-left: 0;
                
                    display: block;
                
                    font-family:Montserrat !important;;
                }.tdi_10 .tdb-logo-text-title{
                    display: block;
                
                    color: #ffffff;
                }.tdi_10 .tdb-logo-text-wrap{
                    flex-direction: column;
                
                    align-items: center;
                }.tdi_10 .tdb-logo-icon{
                    top: 0px;
                
                    display: block;
                }@media (max-width: 767px) {
                  .tdb_header_logo .tdb-logo-text-title {
                    font-size: 36px;
                  }
                }@media (max-width: 767px) {
                  .tdb_header_logo .tdb-logo-text-tagline {
                    font-size: 11px;
                  }
                }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_10 .tdb-logo-img{
                    max-width: 186px;
                }.tdi_10 .tdb-logo-text-tagline{
                    margin-top: -2px;
                    margin-left: 0;
                }
}

/* phone */
@media (max-width: 767px){
.tdi_10 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                    display: none;
                }.tdi_10 .tdb-logo-img-wrap{
                    display: block;
                }.tdi_10 .tdb-logo-text-title{
                    font-family:Roboto !important;font-size:20px !important;font-weight:900 !important;text-transform:uppercase !important;letter-spacing:1px !important;;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://www.databasejournal.com/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img td-retina-data" data-retina="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_RetinaMobile-Logo-copy-2.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20751%20111'%3E%3C/svg%3E" alt="Logo"  title=""  width="751" height="111" data-lazy-src="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_MobileLogo-copy-2.png" /><noscript><img class="tdb-logo-img td-retina-data" data-retina="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_RetinaMobile-Logo-copy-2.png" src="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_MobileLogo-copy-2.png" alt="Logo"  title=""  width="751" height="111" /></noscript></span></a></div></div> <!-- ./block --></div></div><div class="vc_column tdi_12  wpb_column vc_column_container tdc-column td-pb-span4">
<style scoped>

/* custom css */
.tdi_12{
                    vertical-align: baseline;
                }.tdi_12 > .wpb_wrapper,
				.tdi_12 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_12 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_12 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_12 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_12{
                    vertical-align: middle;
                }
}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_12{
width:20% !important;
display:inline-block !important;
}
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_search tdi_13 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_13" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_13{
margin-right:-19px !important;
margin-bottom:0px !important;
}
}

</style>
<style>
/* custom css */
.tdb_mobile_search{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_mobile_search a{
                  display: inline-block !important;
                  position: relative;
                  text-align: center;
                  color: #4db2ec;
                }.tdb_mobile_search a > span{
                  display: flex;
                  align-items: center;
                  justify-content: center;
                }.tdb_mobile_search svg{
                  height: auto;
                }.tdb_mobile_search svg,
                .tdb_mobile_search svg *{
                  fill: #4db2ec;
                }#tdc-live-iframe .tdb_mobile_search a{
                  pointer-events: none;
                }.tdi_13{
                    display: inline-block;
                
                    float: right;
                    clear: none;
                }.tdi_13 .tdb-header-search-button-mob i{
                    font-size: 22px;
                
                    width: 55px;
					height: 55px;
					line-height:  55px;
                }.tdi_13 .tdb-header-search-button-mob svg{
                    width: 22px;
                }.tdi_13 .tdb-header-search-button-mob .tdb-mobile-search-icon-svg{
                    width: 55px;
					height: 55px;
					display: flex;
                    justify-content: center;
                }.tdi_13 .tdb-header-search-button-mob{
                    color: #1c3552;
                }.tdi_13 .tdb-header-search-button-mob svg,
                .tdi_13 .tdb-header-search-button-mob svg *{
                    fill: #1c3552;
                }.tdi_13 .tdb-header-search-button-mob:hover{
                    color: #67bb51;
                }
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-header-search-button-mob dropdown-toggle" href="#" role="button" aria-label="Search" data-toggle="dropdown"><i class="tdb-mobile-search-icon td-icon-search"></i></a></div></div> <!-- ./block --></div></div></div></div></div></div>                    </div>
                                    <div class="td-header-mobile-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
                        <div id="tdi_14" class="tdc-zone"><div class="tdc_zone tdi_15  wpb_row td-pb-row" data-sticky-offset="0" >
<style scoped>

/* custom css */
.tdi_15{
                    min-height: 0;
                }.td-header-mobile-sticky-wrap.td-header-active{
                    opacity: 1;
                }
</style><div id="tdi_16" class="tdc-row"><div class="vc_row tdi_17  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_17,
                .tdi_17 .tdc-columns{
                    min-height: 0;
                }.tdi_17,
				.tdi_17 .tdc-columns{
				    display: block;
				}.tdi_17 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_19  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_19{
                    vertical-align: baseline;
                }.tdi_19 > .wpb_wrapper,
				.tdi_19 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_19 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_19 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_19 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"></div></div></div></div></div></div>                    </div>
                
                    <div class="td-header-desktop-wrap ">
                        <div id="tdi_20" class="tdc-zone"><div class="tdc_zone tdi_21  wpb_row td-pb-row tdc-element-style"  >
<style scoped>

/* custom css */
.tdi_21{
                    min-height: 0;
                }.td-header-desktop-wrap{
                    position: relative;
                }
/* inline tdc_css att */

.tdi_21{
position:relative;
}

</style>
<div class="tdi_20_rand_style td-element-style" ><style>
.tdi_20_rand_style{
background-color:#ffffff !important;
}
 </style></div><div id="tdi_22" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_23  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_23,
                .tdi_23 .tdc-columns{
                    min-height: 0;
                }.tdi_23,
				.tdi_23 .tdc-columns{
				    display: block;
				}.tdi_23 .tdc-columns{
				    width: 100%;
				}@media (min-width: 768px) {
	                .tdi_23 {
	                    margin-left: -0px;
	                    margin-right: -0px;
	                }
	                .tdi_23 .tdc-row-video-background-error,
	                .tdi_23 .vc_column {
	                    padding-left: 0px;
	                    padding-right: 0px;
	                }
                }
/* inline tdc_css att */

.tdi_23{
position:relative;
}

.tdi_23 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_22_rand_style td-element-style" ><style>
.tdi_22_rand_style{
background-color:#ededed !important;
}
 </style></div><div class="vc_column tdi_25  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_25{
                    vertical-align: baseline;
                }.tdi_25 > .wpb_wrapper,
				.tdi_25 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_25 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_25 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_25 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
/* inline tdc_css att */

.tdi_25{
width:20% !important;
justify-content:flex-end !important;
text-align:right !important;
}

</style><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_socials tdi_26 tdm-content-horiz-left td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_26" >
<style>
/* custom css */
.tdm_block.tdm_block_socials{
                  margin-bottom: 0;
                }.tdm-social-wrapper{
                  *zoom: 1;
                }.tdm-social-wrapper:before,
                .tdm-social-wrapper:after{
                  display: table;
                  content: '';
                  line-height: 0;
                }.tdm-social-wrapper:after{
                  clear: both;
                }.tdm-social-item-wrap{
                  display: inline-block;
                }.tdm-social-item{
                  position: relative;
                  display: inline-block;
                  vertical-align: middle;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                  text-align: center;
                  -webkit-transform: translateZ(0);
                  transform: translateZ(0);
                }.tdm-social-item i{
                  font-size: 14px;
                  color: #4db2ec;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                }.tdm-social-text{
                  display: none;
                  margin-top: -1px;
                  vertical-align: middle;
                  font-size: 13px;
                  color: #4db2ec;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                }.tdm-social-item-wrap:hover i,
                .tdm-social-item-wrap:hover .tdm-social-text{
                  color: #000;
                }.tdm-social-item-wrap:last-child .tdm-social-text{
                  margin-right: 0 !important;
                }
</style>
<style>
.tdi_27 .tdm-social-item i{
					font-size: 14px;
					vertical-align: middle;
				
					line-height: 35px;
				}.tdi_27 .tdm-social-item i.td-icon-twitter,
				.tdi_27 .tdm-social-item i.td-icon-linkedin,
				.tdi_27 .tdm-social-item i.td-icon-pinterest,
				.tdi_27 .tdm-social-item i.td-icon-blogger,
				.tdi_27 .tdm-social-item i.td-icon-vimeo{
					font-size: 11.2px;
				}.tdi_27 .tdm-social-item{
					width: 35px;
					height: 35px;
				
				    margin: 5px 10px 5px 0;
				}.tdi_27 .tdm-social-item-wrap:last-child .tdm-social-item{
				    margin-right: 0 !important;
				}.tdi_27 .tdm-social-item i,
				.tds-team-member2 .tdi_27.tds-social1 .tdm-social-item i{
					color: #1c3552;
				}.tdi_27 .tdm-social-item-wrap:hover i,
				.tds-team-member2 .tdi_27.tds-social1 .tdm-social-item:hover i{
					color: #67bb51;
				}.tdi_27 .tdm-social-text{
					display: none;
				
					margin-left: 2px;
				
					margin-right: 18px;
				}
</style><div class="tdm-social-wrapper tds-social1 tdi_27"><div class="tdm-social-item-wrap"><a href="https://www.facebook.com/DatabaseJournal/"  title="Facebook" class="tdm-social-item"><i class="td-icon-font td-icon-facebook"></i></a><a href="https://www.facebook.com/DatabaseJournal/" class="tdm-social-text" >Facebook</a></div><div class="tdm-social-item-wrap"><a href="https://www.linkedin.com/company/database-journal/about/"  title="Linkedin" class="tdm-social-item"><i class="td-icon-font td-icon-linkedin"></i></a><a href="https://www.linkedin.com/company/database-journal/about/" class="tdm-social-text" >Linkedin</a></div><div class="tdm-social-item-wrap"><a href="https://twitter.com/databasejournal"  title="Twitter" class="tdm-social-item"><i class="td-icon-font td-icon-twitter"></i></a><a href="https://twitter.com/databasejournal" class="tdm-social-text" >Twitter</a></div></div></div></div></div><div class="vc_column tdi_29  wpb_column vc_column_container tdc-column td-pb-span9 td-is-sticky">
<style scoped>

/* custom css */
.tdi_29{
                    vertical-align: baseline;
                }.tdi_29 > .wpb_wrapper,
				.tdi_29 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_29 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_29 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_29 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
/* inline tdc_css att */

.tdi_29{
width:80% !important;
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_search_form tdi_30 td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_30" >
<style>

/* inline tdc_css att */

.tdi_30{
margin-bottom:10px !important;
padding-top:10px !important;
padding-bottom:0px !important;
width:60% !important;
}

</style>
<style>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</style><div class="tdb-block-inner td-fix-index"><form method="get" class="tdb-search-form" action="https://www.databasejournal.com/"><div role="search" class="tdb-search-form-inner"><input id="tdb-search-form-input" class="tdb-search-form-input" type="text" value="" name="s" /><div class="tdb-search-form-border"></div><label for="tdb-search-form-input" class="tdb-search-form-placeholder">looking for something?</label><button class="wpb_button wpb_btn-inverse tdb-search-form-btn" aria-label="Search" type="submit"><span>Search</span></div></form></div></div></div></div></div></div><div id="tdi_31" class="tdc-row tdc-row-is-sticky tdc-rist-top stretch_row_1400 td-stretch-content"><div class="vc_row tdi_32  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
body .tdc-row.tdc-rist-top-active,
                body .tdc-row.tdc-rist-bottom-active{
                  position: fixed;
                  left: 50%;
                  transform: translateX(-50%);
                  z-index: 10000;
                }body .tdc-row.tdc-rist-top-active.td-stretch-content,
                body .tdc-row.tdc-rist-bottom-active.td-stretch-content{
                  width: 100% !important;
                }body .tdc-row.tdc-rist-top-active{
                  top: 0;
                }body .tdc-row.tdc-rist-absolute{
                  position: absolute;
                }body .tdc-row.tdc-rist-bottom-active{
                  bottom: 0;
                }.tdi_32,
                .tdi_32 .tdc-columns{
                    min-height: 0;
                }#tdi_31.tdc-rist-top-active .tdi_32:before,
                #tdi_31.tdc-rist-bottom-active .tdi_32:before{
                    display: block;
                    width: 100vw; 
                    height: 100%;
                    position: absolute;
                    left: 50%;
                    transform: translateX(-50%);
                    box-shadow:  0px 2px 1px 0px rgba(219,219,219,0.51);
                    z-index: 20;
                    pointer-events: none;
                    top: 0;
                }.tdi_32,
				.tdi_32 .tdc-columns{
				    display: block;
				}.tdi_32 .tdc-columns{
				    width: 100%;
				}@media (min-width: 767px) {
                  body.admin-bar .tdc-row.tdc-rist-top-active {
                    top: 32px;
                  }
                }@media (min-width: 768px) {
	                .tdi_32 {
	                    margin-left: -21px;
	                    margin-right: -21px;
	                }
	                .tdi_32 .tdc-row-video-background-error,
	                .tdi_32 .vc_column {
	                    padding-left: 21px;
	                    padding-right: 21px;
	                }
                }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
@media (min-width: 768px) {
	                .tdi_32 {
	                    margin-left: -10px;
	                    margin-right: -10px;
	                }
	                .tdi_32 .tdc-row-video-background-error,
	                .tdi_32 .vc_column {
	                    padding-left: 10px;
	                    padding-right: 10px;
	                }
                }
}
/* inline tdc_css att */

.tdi_32{
padding-top:10px !important;
padding-bottom:4px !important;
position:relative;
}

.tdi_32 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_31_rand_style td-element-style" ><style>
.tdi_31_rand_style{
background-color:#ffffff !important;
}
 </style></div><div class="vc_column tdi_34  wpb_column vc_column_container tdc-column td-pb-span12 td-is-sticky">
<style scoped>

/* custom css */
.tdi_34{
                    vertical-align: baseline;
                }.tdi_34 > .wpb_wrapper,
				.tdi_34 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_34 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_34 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_34 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_35 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_35" >
<style>

/* inline tdc_css att */

.tdi_35{
margin-right:21px !important;
}

</style>
<style>
/* custom css */
.tdi_35{
                    display: inline-block;
                }.tdi_35 .tdb-logo-a,
                .tdi_35 h1{
                    flex-direction: column;
                
                    align-items: center;
                }.tdi_35 .tdb-logo-svg-wrap{
                    display: block;
                }.tdi_35 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                    display: none;
                }.tdi_35 .tdb-logo-img{
                    max-width: 280px;
                }.tdi_35 .tdb-logo-text-tagline{
                    margin-top: -3px;
                    margin-left: 0;
                
                    display: block;
                
                    font-family:Montserrat !important;;
                }.tdi_35 .tdb-logo-text-title{
                    display: block;
                
                    color: #ffffff;
                
                    font-family:Roboto !important;font-size:20px !important;font-weight:900 !important;text-transform:uppercase !important;letter-spacing:1px !important;;
                }.tdi_35 .tdb-logo-text-wrap{
                    flex-direction: column;
                
                    align-items: center;
                }.tdi_35 .tdb-logo-icon{
                    top: 0px;
                
                    display: block;
                }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_35 .tdb-logo-img{
                    max-width: 186px;
                }.tdi_35 .tdb-logo-text-tagline{
                    margin-top: -2px;
                    margin-left: 0;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://www.databasejournal.com/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img td-retina-data" data-retina="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_RetinaLogo-copy-2.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201134%20170'%3E%3C/svg%3E" alt="Logo"  title=""  width="1134" height="170" data-lazy-src="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_MainLogo-copy-2.png" /><noscript><img class="tdb-logo-img td-retina-data" data-retina="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_RetinaLogo-copy-2.png" src="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_MainLogo-copy-2.png" alt="Logo"  title=""  width="1134" height="170" /></noscript></span></a></div></div> <!-- ./block --><div class="td_block_wrap tdb_header_menu tdi_36 tds_menu_active1 tds_menu_sub_active1 tdb-head-menu-inline tdb-mm-align-screen td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_36"  style=" z-index: 999;">
<style>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</style>
<style>
.tdi_36 .tdb-menu > li > a:after,
				.tdi_36 .tdb-menu-items-dropdown .td-subcat-more:after{
					background-color: #67bb51;
				
					bottom: 0px;
				}
</style>
<style>

</style><div id=tdi_36 class="td_block_inner td-fix-index"><div class="tdb-main-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-down tdb-main-sub-menu-icon"></i></div><div class="tdb-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-right-arrow"></i></div><ul id="menu-header-menu-1" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16005"><a href="https://www.databasejournal.com/database-news/"><div class="tdb-menu-item-text">Database News</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16007"><a href="https://www.databasejournal.com/features/"><div class="tdb-menu-item-text">Features</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16015"><a href="https://www.databasejournal.com/scripts/"><div class="tdb-menu-item-text">Scripts</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16010"><a href="https://www.databasejournal.com/mysql/"><div class="tdb-menu-item-text">MySQL</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16009"><a href="https://www.databasejournal.com/ms-sql/"><div class="tdb-menu-item-text">MS SQL</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16011"><a href="https://www.databasejournal.com/oracle/"><div class="tdb-menu-item-text">Oracle</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16008"><a href="https://www.databasejournal.com/ms-access/"><div class="tdb-menu-item-text">MS Access</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16006"><a href="https://www.databasejournal.com/db2/"><div class="tdb-menu-item-text">DB2</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16013"><a href="https://www.databasejournal.com/postgresql/"><div class="tdb-menu-item-text">PostgreSQL</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16014"><a href="https://www.databasejournal.com/sap/"><div class="tdb-menu-item-text">SAP</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16012"><a href="https://www.databasejournal.com/php/"><div class="tdb-menu-item-text">PHP</div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-16618"><a href="https://forums.databasejournal.com/"><div class="tdb-menu-item-text">Forums</div></a></li>
</ul></div></div></div></div></div></div><div id="tdi_39" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_40  wpb_row td-pb-row tdc-row-content-vert-center" >
<style scoped>

/* custom css */
.tdi_40,
                .tdi_40 .tdc-columns{
                    min-height: 0;
                }.tdi_40,
				.tdi_40 .tdc-columns{
				    display: block;
				}.tdi_40 .tdc-columns{
				    width: 100%;
				}@media (min-width: 768px) {
	                .tdi_40 {
	                    margin-left: -14px;
	                    margin-right: -14px;
	                }
	                .tdi_40 .tdc-row-video-background-error,
	                .tdi_40 .vc_column {
	                    padding-left: 14px;
	                    padding-right: 14px;
	                }
                }@media (min-width: 767px) {
                    .tdi_40.tdc-row-content-vert-center,
                    .tdi_40.tdc-row-content-vert-center .tdc-columns {
                        display: flex;
                        align-items: center;
                        flex: 1;
                    }
                    .tdi_40.tdc-row-content-vert-bottom,
                    .tdi_40.tdc-row-content-vert-bottom .tdc-columns {
                        display: flex;
                        align-items: flex-end;
                        flex: 1;
                    }
                    .tdi_40.tdc-row-content-vert-center .td_block_wrap {
                        vertical-align: middle;
                    }
                    .tdi_40.tdc-row-content-vert-bottom .td_block_wrap {
                        vertical-align: bottom;
                    }
                }
/* inline tdc_css att */

.tdi_40{
padding-top:24px !important;
}

.tdi_40 .td_block_wrap{ text-align:left }

/* desktop */ @media(min-width: 1141px) { .tdi_40 { 
display:none !important;
} }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_40{
padding-top:14px !important;
}
}

</style><div class="vc_column tdi_42  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_42{
                    vertical-align: baseline;
                }.tdi_42 > .wpb_wrapper,
				.tdi_42 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_42 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_42 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_42 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="vc_row_inner tdi_44  vc_row vc_inner wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_44{
                    position: relative !important;
                    top: 0;
                    transform: none;
                    -webkit-transform: none;
                }.tdi_44,
				.tdi_44 .tdc-inner-columns{
				    display: block;
				}.tdi_44 .tdc-inner-columns{
				    width: 100%;
				}
</style><div class="vc_column_inner tdi_46  wpb_column vc_column_container tdc-inner-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_46{
                    vertical-align: baseline;
                }.tdi_46 .vc_column-inner > .wpb_wrapper,
				.tdi_46 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_46 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
/* inline tdc_css att */

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_46{
display:none !important;
}
}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px)
{
.tdi_46{
display:none !important;
}
}

</style><div class="vc_column-inner"><div class="wpb_wrapper"></div></div></div></div></div></div></div></div></div></div>                    </div>
                                <div class="td-header-desktop-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
                    <div id="tdi_47" class="tdc-zone"><div class="tdc_zone tdi_48  wpb_row td-pb-row" data-sticky-offset="0" >
<style scoped>

/* custom css */
.tdi_48{
                    min-height: 0;
                }.td-header-desktop-sticky-wrap.td-header-active{
                    opacity: 1;
                }
</style><div id="tdi_49" class="tdc-row"><div class="vc_row tdi_50  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_50,
                .tdi_50 .tdc-columns{
                    min-height: 0;
                }.tdi_50,
				.tdi_50 .tdc-columns{
				    display: block;
				}.tdi_50 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_52  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_52{
                    vertical-align: baseline;
                }.tdi_52 > .wpb_wrapper,
				.tdi_52 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_52 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_52 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_52 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"></div></div></div></div></div></div>                </div>
            </div>
            
    <div id="tdb-autoload-article" data-autoload="off" data-autoload-org-post-id="16679" data-autoload-type="" data-autoload-count="5" >
    <style>
        .tdb-autoload-wrap {
            position: relative;
        }
        .tdb-autoload-wrap .tdb-loader-autoload {
            top: auto !important;
            bottom: 50px !important;
        }
        .tdb-autoload-debug {
            display: none;
            width: 1068px;
            margin-right: auto;
            margin-left: auto;
        }
        @media (min-width: 1019px) and (max-width: 1018px) {
            .tdb-autoload-debug {
                width: 740px;
            }
        }
        @media (max-width: 767px) {
            .tdb-autoload-debug {
                display: none;
                width: 100%;
                padding-left: 20px;
                padding-right: 20px;
            }
        }
    </style>

        <div class="td-main-content-wrap td-container-wrap">
            <div class="tdc-content-wrap">
                <article id="template-id-138"
                    class="post-138 tdb_templates type-tdb_templates status-publish post"                    itemscope itemtype="https://schema.org/Article"                                                                            >
	                                    <!-- LOGIN MODAL -->

                <div id="login-form" class="white-popup-block mfp-hide mfp-with-anim td-login-modal-wrap">
                    <div class="td-login-wrap">
                        <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <form id="loginForm" action="#" method="post">
                                <div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
                                <div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
                                <input type="button"  name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                                
                            </form>
                            
                            
                            
                            
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            <div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.databasejournal.com/privacy-policy/">Privacy Policy</a></div>
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <form id="forgotpassForm" action="#" method="post">
                                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
                                <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            </form>
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                <div id="tdi_53" class="tdc-zone"><div class="tdc_zone tdi_54  wpb_row td-pb-row"  >
<style scoped>

/* custom css */
.tdi_54{
                    min-height: 0;
                }
</style><div id="tdi_55" class="tdc-row"><div class="vc_row tdi_56  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_56,
                .tdi_56 .tdc-columns{
                    min-height: 0;
                }.tdi_56,
				.tdi_56 .tdc-columns{
				    display: block;
				}.tdi_56 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_58  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_58{
                    vertical-align: baseline;
                }.tdi_58 > .wpb_wrapper,
				.tdi_58 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_58 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_58 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_58 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_59 td_block_template_2">
<style>

/* inline tdc_css att */

.tdi_59{
padding-top:20px !important;
padding-bottom:20px !important;
}

</style>
<style>
/* custom css */
.tdi_59.td-a-rec{
					text-align: center;
				}.tdi_59 .td-element-style{
					z-index: -1;
				}
</style><div class="wp-ads-inline-top wp-ads-target" id="wp-ads-1336391794" data-advadstrackid="119" data-advadstrackbid="1"><!-- Start: GAM Ad Slot Render | DBJ Inline Top -->
<div id="inline-top" style="min-width: 300px; width: auto; text-align:center; min-height: 50px; max-height: 250px; height: auto; border:0px solid #efefef;">
    <script>
        window.googletag = window.googletag ||
        {
            cmd: []
        };

        window.googletag.cmd.push(function()
        {
            googletag.display("inline-top");
        });
    </script>
</div>
<!-- End: GAM Ad Slot Render | DBJ Inline Top --></div></div></div></div></div></div><div id="tdi_60" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_61  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_61,
                .tdi_61 .tdc-columns{
                    min-height: 0;
                }.tdi_61,
				.tdi_61 .tdc-columns{
				    display: block;
				}.tdi_61 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_61{
margin-top:40px !important;
}

.tdi_61 .td_block_wrap{ text-align:left }

</style><div class="vc_column tdi_63  wpb_column vc_column_container tdc-column td-pb-span8">
<style scoped>

/* custom css */
.tdi_63{
                    vertical-align: baseline;
                }.tdi_63 > .wpb_wrapper,
				.tdi_63 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_63 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_63 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_63 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_breadcrumbs tdi_64 td-pb-border-top td_block_template_2 tdb-breadcrumbs "  data-td-block-uid="tdi_64" >
<style>

/* inline tdc_css att */

.tdi_64{
margin-bottom:18px !important;
}

</style>
<style>
/* custom css */
.tdb-breadcrumbs{
                  margin-bottom: 11px;
                  font-family: 'Open Sans', 'Open Sans Regular', sans-serif;
                  font-size: 12px;
                  color: #747474;
                  line-height: 18px;
                }.tdb-breadcrumbs a{
                  color: #747474;
                }.tdb-breadcrumbs a:hover{
                  color: #000;
                }.tdb-breadcrumbs .tdb-bread-sep{
                  line-height: 1;
                  vertical-align: middle;
                }.tdb-breadcrumbs .tdb-bread-sep-svg svg{
                  height: auto;
                }.tdb-breadcrumbs .tdb-bread-sep-svg svg,
                .tdb-breadcrumbs .tdb-bread-sep-svg svg *{
                  fill: #c3c3c3;
                }.single-tdb_templates.author-template .tdb_breadcrumbs{
                  margin-bottom: 2px;
                }.tdb_category_breadcrumbs{
                  margin: 21px 0 9px;
                }.search-results .tdb_breadcrumbs{
                  margin-bottom: 2px;
                }.tdi_64 .tdb-bread-sep{
                    font-size: 10px;
                
                    margin: 0 5px;
                }.tdi_64,
				.tdi_64 a{
					color: #9b9b9b;
				}.tdi_64 .tdb-bread-sep-svg svg,
				.tdi_64 .tdb-bread-sep-svg svg *{
				    fill: #9b9b9b;
				}.td-theme-wrap .tdi_64{
					text-align: left;
				}.tdi_64{
					font-family:Varela !important;font-size:14px !important;
				}
</style><div class="tdb-block-inner td-fix-index"><span><a title="" class="tdb-entry-crumb" href="https://www.databasejournal.com/">Home</a></span><i class="tdb-bread-sep td-icon-right"></i><span><a title="View all posts in MySQL" class="tdb-entry-crumb" href="https://www.databasejournal.com/mysql/">MySQL</a></span></div></div><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://www.databasejournal.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.databasejournal.com/mysql/",
                                "name": "MySQL"
                            }
                        }    ]
                        }
                       </script><div class="td_block_wrap tdb_title tdi_65 tdb-single-title td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_65" >
<style>

/* inline tdc_css att */

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_65{
padding-right:0px !important;
}
}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px)
{
.tdi_65{
padding-right:100px !important;
}
}

</style>
<style>
/* custom css */
.tdb_title{
                  margin-bottom: 19px;
                }.tdb_title.tdb-content-horiz-center{
                  text-align: center;
                }.tdb_title.tdb-content-horiz-center .tdb-title-line{
                  margin: 0 auto;
                }.tdb_title.tdb-content-horiz-right{
                  text-align: right;
                }.tdb_title.tdb-content-horiz-right .tdb-title-line{
                  margin-left: auto;
                  margin-right: 0;
                }.tdb-title-text{
                  display: inline-block;
                  position: relative;
                  margin: 0;
                  word-wrap: break-word;
                  font-size: 30px;
                  line-height: 38px;
                  font-weight: 700;
                }.tdb-first-letter{
                  position: absolute;
                  -webkit-user-select: none;
                  user-select: none;
                  pointer-events: none;
                  text-transform: uppercase;
                  color: rgba(0, 0, 0, 0.08);
                  font-size: 6em;
                  font-weight: 300;
                  top: 50%;
                  -webkit-transform: translateY(-50%);
                  transform: translateY(-50%);
                  left: -0.36em;
                  z-index: -1;
                  -webkit-text-fill-color: initial;
                }.tdb-title-line{
                  display: none;
                  position: relative;
                }.tdb-title-line:after{
                  content: '';
                  width: 100%;
                  position: absolute;
                  background-color: #4db2ec;
                  top: 0;
                  left: 0;
                  margin: auto;
                }.tdb-single-title .tdb-title-text{
                  font-size: 41px;
                  line-height: 50px;
                  font-weight: 400;
                }.tdi_65 .tdb-title-text{
					background-color: #1c3552;
					-webkit-background-clip: text;
					-webkit-text-fill-color: transparent;
				
					font-family:Varela !important;font-size:32px !important;line-height:1.2 !important;
				}html[class*='ie'] .tdi_65 .tdb-title-text{
				    background: none;
					color: #1c3552;
				}.tdi_65 .tdb-title-line:after{
					height: 2px;
				
					bottom: 40%;
				}.tdi_65 .tdb-title-line{
					height: 50px;
				}.td-theme-wrap .tdi_65{
					text-align: left;
				}.tdi_65 .tdb-first-letter{
					left: -0.36em;
					right: auto;
				
					font-family:Varela !important;
				}.tdi_65 .tdb-add-text{
					font-family:Varela !important;
				}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
.tdi_65 .tdb-title-text{
					font-family:Varela !important;font-size:48px !important;line-height:1.2 !important;
				}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_65 .tdb-title-text{
					font-family:Varela !important;font-size:36px !important;line-height:1.2 !important;
				}
}

/* phone */
@media (max-width: 767px){
.tdi_65 .tdb-title-text{
					font-family:Varela !important;font-size:26px !important;line-height:1.6 !important;
				}
}
</style><div class="tdb-block-inner td-fix-index"><h1 class="tdb-title-text">mongoDB vs. MySQL</h1><div></div><div class="tdb-title-line"></div></div></div><div class="td_block_wrap tdb_single_author tdi_66 td-pb-border-top td_block_template_2 tdb-post-meta"  data-td-block-uid="tdi_66" >
<style>

/* inline tdc_css att */

.tdi_66{
margin-bottom:0px !important;
}

</style>
<style>
/* custom css */
.tdb-post-meta{
                  margin-bottom: 16px;
                  color: #444;
                  font-family: 'Open Sans', 'Open Sans Regular', sans-serif;
                  font-size: 11px;
                  font-weight: 400;
                  clear: none;
                  vertical-align: middle;
                  line-height: 1;
                }.tdb-post-meta span,
                .tdb-post-meta i,
                .tdb-post-meta time{
                  vertical-align: middle;
                }.tdb_single_author{
                  line-height: 30px;
                }.tdb_single_author a{
                  vertical-align: middle;
                }.tdb_single_author .tdb-block-inner{
                  display: flex;
                  align-items: center;
                }.tdb_single_author .tdb-author-name-wrap{
                  display: flex;
                }.tdb_single_author .tdb-author-name{
                  font-weight: 700;
                  margin-right: 3px;
                }.tdb_single_author .tdb-author-by{
                  margin-right: 3px;
                }.tdb_single_author .tdb-author-photo img{
                  display: block;
                }.tdi_66{
                    display: inline-block;
                }.tdi_66 .tdb-author-name-wrap{
                    align-items: baseline;
                }.tdi_66 .avatar{
                    width: 40px;
                    height: 40px;
                
                    margin-right: 6px;
                
                    border-radius: 50%;
                }.tdi_66 .tdb-author-by{
					color: #9b9b9b;
				
					font-family:Varela !important;font-size:14px !important;text-transform:none !important;
				}.tdi_66 .tdb-author-name{
					color: #67bb51;
				
					font-family:Varela !important;font-size:14px !important;text-transform:none !important;
				}.tdi_66 .tdb-author-name:hover{
					color: #298023;
				}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-author-photo"  href="https://www.databasejournal.com/author/david-manda/" title="David Manda"><img data-del="avatar" alt="David Manda" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2096%2096'%3E%3C/svg%3E" class='avatar pp-user-avatar avatar-96 photo ' height='96' width='96' data-lazy-src="https://www.databasejournal.com/wp-content/uploads/2022/04/IMG-20190728-WA0062-David-Manda-e1649447470595-150x150.jpg"/><noscript><img data-del="avatar" alt="David Manda" src='https://www.databasejournal.com/wp-content/uploads/2022/04/IMG-20190728-WA0062-David-Manda-e1649447470595-150x150.jpg' class='avatar pp-user-avatar avatar-96 photo ' height='96' width='96'/></noscript></a><div class="tdb-author-name-wrap"><span class="tdb-author-by">By</span> <a class="tdb-author-name" href="https://www.databasejournal.com/author/david-manda/">David Manda</a></div></div></div><div class="td_block_wrap tdb_single_date tdi_67 td-pb-border-top td_block_template_2 tdb-post-meta"  data-td-block-uid="tdi_67" >
<style>

/* inline tdc_css att */

.tdi_67{
margin-bottom:2px !important;
margin-left:10px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_67{
margin-right:10px !important;
}
}

</style>
<style>
/* custom css */
.tdb_single_date{
                  line-height: 30px;
                }.tdb_single_date a{
                  vertical-align: middle;
                }.tdb_single_date .tdb-date-icon-svg{
                  position: relative;
                  line-height: 0;
                }.tdb_single_date svg{
                  height: auto;
                }.tdb_single_date svg,
                 .tdb_single_date svg *{
                  fill: #444;
                }.tdi_67{
                    display: inline-block;
                
					color: #9b9b9b;
				
					font-size:14px !important;text-transform:none !important;
				}.tdi_67 svg{
                    width: 14px;
                }.tdi_67 .tdb-date-icon{
                    margin-right: 5px;
                }.tdi_67 svg,
				.tdi_67 svg *{
					fill: #9b9b9b;
				}
</style><div class="tdb-block-inner td-fix-index"><time class="entry-date updated td-module-date" datetime="2022-07-07T21:45:41+00:00">July 7, 2022</time></div></div> <!-- ./block --><div class="td_block_wrap tdb_single_post_share tdi_68 td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_68" >
<style>

/* inline tdc_css att */

.tdi_68{
margin-top:20px !important;
margin-bottom:20px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_68{
margin-bottom:20px !important;
}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_68{
margin-top:10px !important;
margin-bottom:10px !important;
}
}

</style>
<style>
/* custom css */
.tdb_single_post_share{
                  margin-bottom: 23px;
                }.tdb-share-classic{
                  position: relative;
                  height: 20px;
                  margin-bottom: 15px;
                }.tdi_68 .td-social-share-text{
					font-family:Varela !important;
				}.tdi_68 .td-social-network{
					font-family:Varela !important;
				}
</style><div id="tdi_68" class="td-post-sharing tdb-block td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 ">
		<style>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</style>

		<div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.databasejournal.com%2Fmysql%2Fmongodb-vs-mysql-database-journal%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=mongoDB+vs.+MySQL&url=https%3A%2F%2Fwww.databasejournal.com%2Fmysql%2Fmongodb-vs-mysql-database-journal%2F&via=Database+Journal" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/&title=mongoDB+vs.+MySQL" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#c0ffb3b5a2aaa5a3b4fdadafaea7af8482e0b6b3eee08db993918ce6a2afa4b9fda8b4b4b0b3faefefb7b7b7eea4a1b4a1a2a1b3a5aaafb5b2aea1aceea3afadefadb9b3b1acefadafaea7afa4a2edb6b3edadb9b3b1aceda4a1b4a1a2a1b3a5edaaafb5b2aea1acef" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="tdi_68" title="More">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div><div class="td_block_wrap tdb_single_content tdi_69 td-pb-border-top td_block_template_2 td-post-content tagdiv-type"  data-td-block-uid="tdi_69" >
<style>

/* inline tdc_css att */

.tdi_69{
margin-top:0px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_69{
margin-top:0px !important;
}
}

</style>
<style>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</style><div class="tdb-block-inner td-fix-index"><p><img class="alignnone size-full wp-image-16646" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20200%20200'%3E%3C/svg%3E" alt="MySQL tutorials" width="200" height="200" data-lazy-srcset="https://www.databasejournal.com/wp-content/uploads/2010/05/MySQL-icon..jpeg 200w, https://www.databasejournal.com/wp-content/uploads/2010/05/MySQL-icon.-150x150.jpeg 150w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://www.databasejournal.com/wp-content/uploads/2010/05/MySQL-icon..jpeg" /><noscript><img class="alignnone size-full wp-image-16646" src="https://www.databasejournal.com/wp-content/uploads/2010/05/MySQL-icon..jpeg" alt="MySQL tutorials" width="200" height="200" srcset="https://www.databasejournal.com/wp-content/uploads/2010/05/MySQL-icon..jpeg 200w, https://www.databasejournal.com/wp-content/uploads/2010/05/MySQL-icon.-150x150.jpeg 150w" sizes="(max-width: 200px) 100vw, 200px" /></noscript><img class="alignnone size-medium wp-image-16680" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20188'%3E%3C/svg%3E" alt="MongoDB tutorials" width="300" height="188" data-lazy-srcset="https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-300x188.jpg 300w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-1024x640.jpg 1024w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-768x480.jpg 768w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-1536x960.jpg 1536w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-2048x1280.jpg 2048w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-696x435.jpg 696w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-1068x668.jpg 1068w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-1920x1200.jpg 1920w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-672x420.jpg 672w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-300x188.jpg" /><noscript><img class="alignnone size-medium wp-image-16680" src="https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-300x188.jpg" alt="MongoDB tutorials" width="300" height="188" srcset="https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-300x188.jpg 300w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-1024x640.jpg 1024w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-768x480.jpg 768w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-1536x960.jpg 1536w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-2048x1280.jpg 2048w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-696x435.jpg 696w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-1068x668.jpg 1068w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-1920x1200.jpg 1920w, https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb-672x420.jpg 672w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></p>
<p>Changes in customer behavior have caused a new focus for the structure of commercial databases. The flexibility of data storage is essential in fulfilling the demands of customer needs and predicting future business. MongoDB and <a href="https://www.mysql.com/" target="_blank" rel="noopener">MySQL</a> are both valuable database solutions that align to this shift in commercial objectives in database management systems. The difference between the two applications is that MongoDB is an object-based system, while MySQL is a table-based system.</p>
<p>For its part, MongoDB is a database that features bulk data storage through a <a href="https://www.webopedia.com/definitions/nosql/" target="_blank" rel="noopener">NoSQL</a><br />
structure in a document format. The main feature of this software is the option to modify documents and their variables. MySQL, meanwhile, functions through a query system where data can be searched and its point of relation identified.</p>
<p>When deciding between MongoDB vs. MySQL, having knowledge of the language structure is important. MongoDB simplifies the data query process, but MySQL has a proven record of Structured Query Language (SQL) for defining and manipulating data. In order to understand which software is better, this database programming and administration tutorial will analyze the features of these applications to identify which one is better.</p>
<p>If you opt to choose MySQL as your database of choice, you should check out our article: <a href="https://www.databasejournal.com/mysql/mysql-courses-online/" target="_blank" rel="noopener">Best Online Courses to Learn MySQL</a>, which has a great list of database administration classes that will help you get started.</p>
<h2>What is MongoDB?</h2>
<p><a href="https://www.mongodb.com/" target="_blank" rel="noopener">MongoDB</a> is a database management system that uses NoSQL queries, while providing flexibility and scalability functions. MongoDB is a non-relational database system that uses the JavaScript language to search data and modify documents into smaller sizes. Commercial companies rely on MongoDB because it is compatible with multiple storage engines.</p>
<p>The database management software retains a dynamic structure that favors the organization of information, making data modification faster than other database options. This process also makes data management more efficient and faster, especially when large documents need to be encoded into smaller sizes. MongoDB uses JSON and BSON languages to make data management more flexible and lighter to process when compared to MySQL.</p>
<p>MongoDB faces competition from 20 NoSQL database vendors. It leads the market share of other NoSQL databases with a 48.05% lead. The major competitors of MongoDB include NoSQL, with 24.41%, Amazon DynamoDB at 9.74%, and Apache Cassandra with 5.56%. The United States has the highest number of customers of MongoDB with 33.41%, followed by India with 9.95% of customers, and the United Kingdom with 5.84% of users.</p>
<p>MongoDB is typically used for designing specialized data sets through document compression and is able to adapt to data variations. Geospatial data format does not require technical monitoring when structures show variation, because MongoDB has resilient data structures. MongoDB also functions in multi-cloud application environments. The database system can execute cloud services based on personal configuration to support both current and future software needs. Healthcare, gaming, retail, telecommunications, and finance industries &#8211; to name but a few &#8211; rely on MongoDB for software development for database-driven applications, data management, data analytics, and solutions to server issues.</p>
<h3>Benefits of MongoDB</h3>
<p>Below are some of the key benefits of MongoDB:</p>
<ul>
<li>Scalability is a significant benefit of using MongoDB because it is easy to organize the database system laterally and scale per software requirements.</li>
<li>The storage structure of MongoDB supports the addition of any file regardless of its size without disrupting the file stack.</li>
<li>MongoDB can improve the performance of database systems with the configuration of indexes. Documents that use MongoDB can alternate the index field.</li>
<li>MongoDB improves the performance of servers by adjusting the data load or replicating files when the system is struggling. The application also supports multiple servers and offers improved functionality over other options.</li>
<li>Aggregation process is possible when using MongoDB, which means aggregation commands, aggregation pipeline, and map reduce operations are supported.</li>
<li>The replication of documents in the database is quicker and more flexible when using MongoDB.</li>
</ul>
<h3>What are MongoDB’s Cons?</h3>
<p>Below are some of what we consider to be MongoDB’s cons and negatives:</p>
<ul>
<li>MongoDB has a complex procedure for performing transactions that is tedious and time consuming.</li>
<li>ACID (Atomic, Consistency, Isolation, and Durability) certification is absent in the system catalog, especially for data transactions. This feature is available in other relational database management systems.</li>
<li>MongoDB does not operate like most relational database systems, which means it lacks support for Stored Procedures or commands. The addition of a business structure is impossible in the database system.</li>
</ul>
<p>You can learn more about MongoDB&#8217;s latest features and updates by reading our cousin sites coverage of <a href="https://www.eweekuk.com/database/mongodb-world-2022-database-tools-for-a-cloud-first-world/" target="_blank" rel="noopener">MongoDB&#8217;s Conference</a>.</p>
<h2>What is MySQL?</h2>
<p>MySQL is a relational database system that serves client-server systems in storing data. It is a reliable system that supports the classification of data in rows and tables. MySQL operates through the master-slave approach, where replication and backup of data is possible, making it very reliable. Atomic Data Definition Language is also possible with MySQL, which provides storage engine operations and updates for the data dictionary to simplify transactions.</p>
<p>MySQL ranks second in the world in the database market. The relational database management system has 44.04% of the market share based on its support for web development and applications like phpBB and WordPress. MySQL is easy to customize and is open-source software.</p>
<p>Small, mid-sized, and large enterprises can use MySQL for data storage management because of its built-in functions. The software has a 31.39% market share in the USA and has a proven record of being scalable to major business functions, like marketing. Twitter and Facebook are popular social media websites that were developed, in part, through MySQL. Oracle is the major competitor to MySQL in the database management market.</p>
<h3>Benefits of MySQL</h3>
<p>Below are some of the benefits of using MySQL:</p>
<ul>
<li>The security protocols used in MySQL are complex enough to prevent exposure of private databases when developing web applications. Web designers can rely on security algorithms that deny exposure of information, especially for regular web users.</li>
<li>MySQL can function on multiple servers and is easily accessible to most database systems. The high portability of the software makes it easier for users to complete web functions from any location.</li>
<li>Since MySQL is open-source software, any web developer can use its services to store and manage data for most functions. Commercial enterprises with limited investment can use the database system to grow their business with little effort or cost.</li>
</ul>
<h3>Cons of MySQL</h3>
<p>Some of the cons of MySQL include:</p>
<ul>
<li>MySQL lacks a server cache for stored procedures. This condition means the operator must repeat the data input procedure after the process concludes.</li>
<li>The system catalog is susceptible to corruption when a server crash occurs. This process can cause loss of data and time spent recovering the database system.</li>
<li>MySQL cannot process bulk data, which can limit the performance ability of commercial enterprises. The software is not as fast as industry standards for data processing.</li>
<li>Support for MySQL is limited because it is open-source software. This condition means security updates or reports on server bugs may not be as available compared to paid subscription software. MySQL cannot support innovative web development functions especially significant to commercial companies.</li>
</ul>
<p><strong>Read:</strong> <a href="https://www.databasejournal.com/mysql/the-10-most-common-mysql-queries/" target="_blank" rel="noopener">Top Common MySQL Queries</a></p>
<h2>Database Comparison: MySQL versus MongoDB</h2>
<p>Below, we compare the differences between MySQL and MongoDB database solutions.</p>
<h3>User-friendliness</h3>
<p>MongoDB is more user-friendly than MySQL. MongoDB has a predefined structure that supports the entry of different information to the database without having similar fields. However, MySQL demands the configuration of columns and tables. Also, the structure of the database cannot be changed depending on the number of columns.</p>
<p>In terms of structured and unstructured data, MongoDB is better than MySQL; this is because MongoDB functions as an object database system, while MySQL functions as a relational database system. The support for a database system with rapid web development is possible with MongoDB and not MySQL.</p>
<h3>Features</h3>
<p>MySQL uses the Structured Query Language &#8211; or SQL &#8211; while MongoDB functions through JavaScript as a query language. Some consider MongoDB is to be better than MySQL because the design of data structures is limitless.</p>
<p>MongoDB supports cloud-based services that are essential to online transactions and data storage management. MySQL does not support cloud-based services because its priority is data security. MongoDB is better than MySQL because of this feature gets a slight edge here if you are a cloud developer.</p>
<p>Software support is consistent with MongoDB because the company publishes bug reports and security updates as a part of the ongoing development of the software. Oracle develops updates and fixing problems relating to MySQL. However, the updates are not frequent on MySQL, which makes MongoDB the winner here.</p>
<h3>Integrations</h3>
<p>MongoDB integrates with multiple storage engines with a dynamic structure design that favors simpler configuration for data management. The software uses JSON language and MongoDB query language to change the structure of JSON and BSON documents. In contrast, MySQL uses the Structured Query Language to organize and manage databases. MySQL supports C, C++, and JavaScript languages. MongoDB is more flexible than MySQL in integrating databases because it can embed additional data in existing file stacks. From an integration perspective, these two are evenly matched.</p>
<h3>Collaboration</h3>
<p>MySQL makes it simpler easier to execute structured commands because it uses Structured Query Language. This condition means creating commands for data queryries is easier because of Data Definition Language and Data Manipulation Language. With MySQL, you can link several documents and data with minimal commands. In contrast, MongoDB requires several commands to execute data configurations because it uses a non-structure system. MySQL is better for collaboration because combining different files is easier in MySQL than it is in MongoDB.</p>
<h3>Pricing</h3>
<p>MySQL is better than MongoDB in pricing for small businesses and individuals because it is open-source software. This standard means that any web developer or business can use the software for database system management. The <b>Enterprise Edition</b> of MySQL costs $5000 annually for web developers and end -users.</p>
<p>MongoDB requires a licensing fee for its <b>Enterprise Edition</b> that includes additional security protocols, data monitoring, authentication, administration, and a memory storage engine. This package costs $57 per month. The open-source version of MongoDB is less advanced in functionality compared to the paid option. For this reason, MongoDB is better than MySQL..</p>
<h3>The Verdict: MySQL or MongoDB</h3>
<p>MongoDB is better than MySQL because it takes a shorter time into query data, which is that is important for managing databases relating to customer behavior. Although when handling structured data, MySQL is better than MongoDB,; when there is a query against unstructured data, MongoDB is preferential. In the database management market, speed and performance are significant to many businesses. MongoDB can deliver speed and performance given its fast queries of data, as well as the ability to handle both structured and unstructured data.</p>
<p>Real-time analytics is a benefit that comes with MongoDB and gaining quick query results is possible through object database systems like MongoDB. With MySQL, the data queries take longer, so configuration can delay after updates. However, in terms of security protocols to protect private information, MySQL is better than MongoDB because it uses a relational database system.</p>
<p>At the end of the day, there are many factors that might make you choose one database over another. Weigh the benefits and drawbacks of each against the needs of your particular project.</p>
<p>Looking for more database comparisons? Check out our article on <a href="https://www.databasejournal.com/mysql/postgresql-vs-mysql-which-is-best/" target="_blank" rel="noopener">PostgreSQL vs MySQL</a>.</p>
</div></div><div class="td_block_wrap tdb_single_post_share tdi_70 td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_70" >
<style>

/* inline tdc_css att */

.tdi_70{
margin-top:20px !important;
margin-bottom:60px !important;
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_70{
margin-top:15px !important;
margin-bottom:40px !important;
}
}

</style><div id="tdi_70" class="td-post-sharing tdb-block td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.databasejournal.com%2Fmysql%2Fmongodb-vs-mysql-database-journal%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=mongoDB+vs.+MySQL&url=https%3A%2F%2Fwww.databasejournal.com%2Fmysql%2Fmongodb-vs-mysql-database-journal%2F&via=Database+Journal" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/&title=mongoDB+vs.+MySQL" title="Linkedin" ><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#08377b7d6a626d6b7c356567666f674c4a287e7b262845715b59442e6a676c7135607c7c787b3227277f7f7f266c697c696a697b6d62677d7a666964266b67652765717b7964276567666f676c6a257e7b2565717b7964256c697c696a697b6d2562677d7a66696427" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="tdi_70" title="More">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div><div class="tdb-author-box td_block_wrap tdb_single_author_box tdi_71 tdb-content-vert-top td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_71" >
<style>

/* inline tdc_css att */

.tdi_71{
margin-bottom:60px !important;
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_71{
margin-bottom:40px !important;
}
}

</style>
<style>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</style><div class="tdb-block-inner td-fix-index"><a href="https://www.databasejournal.com/author/david-manda/" class="tdb-author-photo" title="David Manda"><img data-del="avatar" alt="David Manda" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20500%20500'%3E%3C/svg%3E" class='avatar pp-user-avatar avatar-500 photo ' height='500' width='500' data-lazy-src="https://www.databasejournal.com/wp-content/uploads/2022/04/IMG-20190728-WA0062-David-Manda-e1649447470595.jpg"/><noscript><img data-del="avatar" alt="David Manda" src='https://www.databasejournal.com/wp-content/uploads/2022/04/IMG-20190728-WA0062-David-Manda-e1649447470595.jpg' class='avatar pp-user-avatar avatar-500 photo ' height='500' width='500'/></noscript></a><div class="tdb-author-info"><a href="https://www.databasejournal.com/author/david-manda/" class="tdb-author-name">David Manda</a><div class="tdb-author-descr">David Manda is a contributing writer for Database Journal. His background is in education, technology, and digital marketing.</div><div class="tdb-author-social"></div></div></div></div><div class="td_block_wrap tdb_single_next_prev tdi_72 td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_72" >
<style>

/* inline tdc_css att */

.tdi_72{
margin-bottom:60px !important;
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_72{
margin-bottom:40px !important;
}
}

/* phone */
@media (max-width: 767px)
{
.tdi_72{
margin-bottom:40px !important;
}
}

</style>
<style>
/* custom css */
.tdb_single_next_prev{
                  *zoom: 1;
                }.tdb_single_next_prev:before,
                .tdb_single_next_prev:after{
                  display: table;
                  content: '';
                  line-height: 0;
                }.tdb_single_next_prev:after{
                  clear: both;
                }.tdb-next-post{
                  font-family: 'Roboto', sans-serif;
                  width: 48%;
                  float: left;
                  transform: translateZ(0);
                  -webkit-transform: translateZ(0);
                  min-height: 1px;
                  line-height: 1;
                }.tdb-next-post span{
                  display: block;
                  font-size: 12px;
                  color: #747474;
                  margin-bottom: 7px;
                }.tdb-next-post a{
                  font-size: 15px;
                  color: #222;
                  line-height: 21px;
                  -webkit-transition: color 0.2s ease;
                  transition: color 0.2s ease;
                }.tdb-next-post a:hover{
                  color: #4db2ec;
                }.tdb-post-next{
                  margin-left: 2%;
                  text-align: right;
                }.tdb-post-prev{
                  margin-right: 2%;
                }.tdi_72 .tdb-next-post{
					padding: 20px;
				}.tdi_72 .tdb-next-post-bg{
					background-color: #1c3552;
				}.tdi_72 .tdb-next-post a{
					color: #ffffff;
				
					font-family:Varela !important;font-size:20px !important;line-height:1.4 !important;
				}.tdi_72 .tdb-next-post:hover a{
					color: #67bb51;
				}.tdi_72 .tdb-next-post span{
					color: #ffffff;
				
					font-family:Varela !important;font-size:16px !important;
				}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){

}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_72 .tdb-next-post a{
					font-family:Varela !important;font-size:14px !important;line-height:1.4 !important;
				}
}

/* phone */
@media (max-width: 767px){
.tdi_72 .tdb-next-post a{
					font-family:Varela !important;font-size:12px !important;line-height:1.4 !important;
				}
}
</style><div class="tdb-block-inner td-fix-index"><div class="tdb-next-post tdb-next-post-bg tdb-post-prev"><span>Previous article</span><a href="https://www.databasejournal.com/mysql/mysql-courses-online/">Best Online Courses to Learn MySQL</a></div></div></div><div class="td_block_wrap tdb_single_related tdi_73 td_with_ajax_pagination td-pb-border-top td_block_template_8 tdb-single-related-posts"  data-td-block-uid="tdi_73" >
<style>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</style>
<style>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</style><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>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</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span>Related Articles</span></h4></div><div id=tdi_73 class="td_block_inner tdb-block-inner td-fix-index">
        <div class="tdb_module_related td_module_wrap td-animation-stack">
            <div class="td-module-container td-category-pos-above">
                
                <div class="td-module-meta-info">
                    <a href="https://www.databasejournal.com/features/" class="td-post-category">Features</a>
                    <h3 class="entry-title td-module-title"><a href="https://www.databasejournal.com/mysql/mysql-courses-online/" rel="bookmark" title="Best Online Courses to Learn MySQL">Best Online Courses to Learn MySQL</a></h3>
                    
                    <div class="td-editor-date">
                        
                        <span class="td-author-date">
                                                        <span class="td-post-author-name"><a href="https://www.databasejournal.com/author/james-payne/">James Payne</a> <span>-</span> </span>                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-28T19:51:22+00:00" >June 28, 2022</time></span>                                                                                </span>
                    </div>

                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="tdb_module_related td_module_wrap td-animation-stack">
            <div class="td-module-container td-category-pos-above">
                
                <div class="td-module-meta-info">
                    <a href="https://www.databasejournal.com/mysql/" class="td-post-category">MySQL</a>
                    <h3 class="entry-title td-module-title"><a href="https://www.databasejournal.com/mysql/postgresql-vs-mysql-which-is-best/" rel="bookmark" title="PostgreSQL vs. MySQL: Which Is Best?">PostgreSQL vs. MySQL: Which Is Best?</a></h3>
                    
                    <div class="td-editor-date">
                        
                        <span class="td-author-date">
                                                        <span class="td-post-author-name"><a href="https://www.databasejournal.com/author/david-manda/">David Manda</a> <span>-</span> </span>                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-04-08T19:01:28+00:00" >April 8, 2022</time></span>                                                                                </span>
                    </div>

                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="tdb_module_related td_module_wrap td-animation-stack">
            <div class="td-module-container td-category-pos-above">
                
                <div class="td-module-meta-info">
                    <a href="https://www.databasejournal.com/mysql/" class="td-post-category">MySQL</a>
                    <h3 class="entry-title td-module-title"><a href="https://www.databasejournal.com/mysql/the-10-most-common-mysql-queries/" rel="bookmark" title="Top Common MySQL Queries">Top Common MySQL Queries</a></h3>
                    
                    <div class="td-editor-date">
                        
                        <span class="td-author-date">
                                                        <span class="td-post-author-name"><a href="https://www.databasejournal.com/author/kelseyperkins/">Kelsey Perkins</a> <span>-</span> </span>                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-04-05T14:09:00+00:00" >April 5, 2022</time></span>                                                                                </span>
                    </div>

                    
                    
                                    </div>
            </div>
        </div>

        </div></div>

<script>

var tdb_login_sing_in_shortcode="on";

</script>

<div class="td_block_wrap tdb_single_comments tdi_74 tdb-comm-layout2 td-pb-border-top td_block_template_8"  data-td-block-uid="tdi_74" >
<style>
.tdi_74 .td-block-title > * {
                color: #1c3552 !important;
            }
/* inline tdc_css att */

.tdi_74{
margin-top:40px !important;
}

</style>
<style>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</style><div class="tdb-block-inner td-fix-index"><div class="comments" id="comments"></div></div></div></div></div><div class="vc_column tdi_76  wpb_column vc_column_container tdc-column td-pb-span4 td-is-sticky">
<style scoped>

/* custom css */
.tdi_76{
                    vertical-align: baseline;
                }.tdi_76 > .wpb_wrapper,
				.tdi_76 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_76 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_76 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_76 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap td_flex_block_1 tdi_77 td-pb-border-top td_block_template_2 td_flex_block"  data-td-block-uid="tdi_77" >
<style>
.td_block_template_2.widget > ul > li {
                margin-left: 0 !important;
            }
            
            .td_block_template_2 .td-block-title {
                font-size: 17px;
                font-weight: 500;
                margin-top: 0;
                margin-bottom: 16px;
                line-height: 31px;
                text-align: left;
            }
            .td_block_template_2 .td-block-title > * {
                color: #000;
            }
            .td_block_template_2 .td-related-title a {
                padding: 0 20px 0 0;
            }
            @media (max-width: 767px) {
                .td_block_template_2 .td-related-title a {
                    font-size: 15px;
                }
            }
            .td_block_template_2 .td-related-title .td-cur-simple-item {
                color: #4db2ec;
            }
</style>
<style>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</style><script>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</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Latest Articles</span></h4></div><div id=tdi_77 class="td_block_inner td-mc1-wrap">
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-">
                
                <div class="td-module-meta-info">
                                        
                    <h3 class="entry-title td-module-title"><a href="https://www.databasejournal.com/mysql/mysql-courses-online/" rel="bookmark" title="Best Online Courses to Learn MySQL">Best Online Courses to Learn MySQL</a></h3>
                    
                                            <div class="td-editor-date">
                                                        <a href="https://www.databasejournal.com/features/" class="td-post-category">Features</a>
                                                            <span class="td-author-date">
                                                                        <span class="td-post-author-name"><a href="https://www.databasejournal.com/author/james-payne/">James Payne</a> <span>-</span> </span>                                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-28T19:51:22+00:00" >June 28, 2022</time></span>                                                                                                        </span>
                                                    </div>
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-">
                
                <div class="td-module-meta-info">
                                        
                    <h3 class="entry-title td-module-title"><a href="https://www.databasejournal.com/mysql/postgresql-vs-mysql-which-is-best/" rel="bookmark" title="PostgreSQL vs. MySQL: Which Is Best?">PostgreSQL vs. MySQL: Which Is Best?</a></h3>
                    
                                            <div class="td-editor-date">
                                                        <a href="https://www.databasejournal.com/mysql/" class="td-post-category">MySQL</a>
                                                            <span class="td-author-date">
                                                                        <span class="td-post-author-name"><a href="https://www.databasejournal.com/author/david-manda/">David Manda</a> <span>-</span> </span>                                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-04-08T19:01:28+00:00" >April 8, 2022</time></span>                                                                                                        </span>
                                                    </div>
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-">
                
                <div class="td-module-meta-info">
                                        
                    <h3 class="entry-title td-module-title"><a href="https://www.databasejournal.com/mysql/the-10-most-common-mysql-queries/" rel="bookmark" title="Top Common MySQL Queries">Top Common MySQL Queries</a></h3>
                    
                                            <div class="td-editor-date">
                                                        <a href="https://www.databasejournal.com/mysql/" class="td-post-category">MySQL</a>
                                                            <span class="td-author-date">
                                                                        <span class="td-post-author-name"><a href="https://www.databasejournal.com/author/kelseyperkins/">Kelsey Perkins</a> <span>-</span> </span>                                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-04-05T14:09:00+00:00" >April 5, 2022</time></span>                                                                                                        </span>
                                                    </div>
                    
                    
                    
                                    </div>
            </div>
        </div>

        
        <div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack ">
            <div class="td-module-container td-category-pos-">
                
                <div class="td-module-meta-info">
                                        
                    <h3 class="entry-title td-module-title"><a href="https://www.databasejournal.com/features/top-10-mysql-gui-tools/" rel="bookmark" title="Top Ten MySQL GUI Tools">Top Ten MySQL GUI Tools</a></h3>
                    
                                            <div class="td-editor-date">
                                                        <a href="https://www.databasejournal.com/mysql/" class="td-post-category">MySQL</a>
                                                            <span class="td-author-date">
                                                                        <span class="td-post-author-name"><a href="https://www.databasejournal.com/author/kelseyperkins/">Kelsey Perkins</a> <span>-</span> </span>                                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-03-18T14:00:00+00:00" >March 18, 2022</time></span>                                                                                                        </span>
                                                    </div>
                    
                    
                    
                                    </div>
            </div>
        </div>

        </div></div><div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_78 td_block_template_2">
<style>

/* inline tdc_css att */

.tdi_78{
padding-bottom:100px !important;
}

</style>
<style>
/* custom css */
.tdi_78.td-a-rec{
					text-align: center;
				}.tdi_78 .td-element-style{
					z-index: -1;
				}.tdi_78.td-a-rec-img{
				    text-align: left;
				}.tdi_78.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_78.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><div class="wp-ads-sticky-rail wp-ads-target" id="wp-ads-901533012" data-advadstrackid="121" data-advadstrackbid="1"><!-- Start: GAM Ad Slot Render | DBJ Sticky Rail -->
<div id="sticky-rail" style="max-width: 300px; min-width: 160px; width: auto; text-align:center; min-height: 250px; max-height: 600px; height: auto; background-color: #ffffff; border:0px solid #efefef;">
    <script>
        window.googletag = window.googletag ||
        {
            cmd: []
        };

        window.googletag.cmd.push(function()
        {
            googletag.display("sticky-rail");
        });
    </script>
</div>
<!-- End: GAM Ad Slot Render | DBJ Sticky Rail --></div></div></div></div></div></div></div></div>                    <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="David Manda"><meta itemprop="url" content="https://www.databasejournal.com/author/david-manda/"></span><meta itemprop="datePublished" content="2022-07-07T21:45:41+00:00"><meta itemprop="dateModified" content="2022-07-07T21:46:23+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.databasejournal.com/mysql/mongodb-vs-mysql-database-journal/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_MainLogo-copy-2-300x45.png"></span><meta itemprop="name" content="Database Journal"></span><meta itemprop="headline" content="mongoDB vs. MySQL"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.databasejournal.com/wp-content/uploads/2022/07/mongodb.jpg"><meta itemprop="width" content="2400"><meta itemprop="height" content="1500"></span>                </article>
            </div>
        </div>
        
    </div> <!-- #tdb-autoload-article -->

<!-- Instagram -->
    <div class="td-footer-template-wrap" style="position: relative">
                <div class="td-footer-wrap ">
            <div id="tdi_79" class="tdc-zone"><div class="tdc_zone tdi_80  wpb_row td-pb-row tdc-element-style"  >
<style scoped>

/* custom css */
.tdi_80{
                    min-height: 0;
                }.tdi_80 > .td-element-style:after{
                    content: '' !important;
                    width: 100% !important;
                    height: 100% !important;
                    position: absolute !important;
                    top: 0 !important;
                    left: 0 !important;
                    z-index: 0 !important;
                    display: block !important;
                    background-color: #1c3552 !important;
                }
</style>
<div class="tdi_79_rand_style td-element-style" ></div><div id="tdi_81" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_82  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_82,
                .tdi_82 .tdc-columns{
                    min-height: 0;
                }.tdi_82,
				.tdi_82 .tdc-columns{
				    display: block;
				}.tdi_82 .tdc-columns{
				    width: 100%;
				}@media (min-width: 768px) {
	                .tdi_82 {
	                    margin-left: -15px;
	                    margin-right: -15px;
	                }
	                .tdi_82 .tdc-row-video-background-error,
	                .tdi_82 .vc_column {
	                    padding-left: 15px;
	                    padding-right: 15px;
	                }
                }

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
@media (min-width: 768px) {
	                .tdi_82 {
	                    margin-left: -10px;
	                    margin-right: -10px;
	                }
	                .tdi_82 .tdc-row-video-background-error,
	                .tdi_82 .vc_column {
	                    padding-left: 10px;
	                    padding-right: 10px;
	                }
                }
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
@media (min-width: 768px) {
	                .tdi_82 {
	                    margin-left: -10px;
	                    margin-right: -10px;
	                }
	                .tdi_82 .tdc-row-video-background-error,
	                .tdi_82 .vc_column {
	                    padding-left: 10px;
	                    padding-right: 10px;
	                }
                }
}
/* inline tdc_css att */

.tdi_82{
padding-top:60px !important;
}

.tdi_82 .td_block_wrap{ text-align:left }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_82{
padding-top:30px !important;
padding-bottom:10px !important;
}
}

</style><div class="vc_column tdi_84  wpb_column vc_column_container tdc-column td-pb-span6">
<style scoped>

/* custom css */
.tdi_84{
                    vertical-align: baseline;
                }.tdi_84 > .wpb_wrapper,
				.tdi_84 > .wpb_wrapper > .tdc-elements{
				    display: flex;
				
				    flex-direction: column;
				
				    flex-wrap: nowrap;
				
				    justify-content: flex-start;
				
				    align-items: flex-start;
				}.tdi_84 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_84 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_84 > .wpb_wrapper{
				    width: 100%;
				    height: 100%;
				}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_84{
justify-content:center !important;
text-align:center !important;
}
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_85 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_85" >
<style>

/* inline tdc_css att */

.tdi_85{
margin-top:10px !important;
margin-bottom:10px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_85{
margin-left:50px !important;
display:inline-block !important;
}
}

</style>
<style>
/* custom css */
.tdi_85{
                    display: inline-block;
                }.tdi_85 .tdb-logo-a,
                .tdi_85 h1{
                    flex-direction: row;
                
                    align-items: center;
                
                    justify-content: center;
                }.tdi_85 .tdb-logo-svg-wrap{
                    display: block;
                }.tdi_85 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                    display: none;
                }.tdi_85 .tdb-logo-img{
                    max-width: 50%;
                }.tdi_85 .tdb-logo-img-wrap{
                    display: block;
                }.tdi_85 .tdb-logo-text-tagline{
                    margin-top: 2px;
                    margin-left: 0;
                
                    display: block;
                
                    font-family:Montserrat !important;;
                }.tdi_85 .tdb-logo-text-title{
                    display: block;
                
                    color: #ffffff;
                
                    font-family:Montserrat !important;font-size:34px !important;font-weight:500 !important;text-transform:uppercase !important;;
                }.tdi_85 .tdb-logo-text-wrap{
                    flex-direction: column;
                
                    align-items: center;
                }.tdi_85 .tdb-logo-icon{
                    top: 0px;
                
                    display: block;
                }

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
.tdi_85 .tdb-logo-text-title{
                    font-family:Montserrat !important;font-size:32px !important;font-weight:500 !important;text-transform:uppercase !important;;
                }
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_85 .tdb-logo-text-title{
                    font-family:Montserrat !important;font-size:22px !important;font-weight:500 !important;text-transform:uppercase !important;;
                }
}

/* phone */
@media (max-width: 767px){
.tdi_85 .tdb-logo-img{
                    max-width: 80%;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://www.databasejournal.com/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img td-retina-data" data-retina="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_RetinaMobile-Logo-copy-3.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201134%20171'%3E%3C/svg%3E" alt="Logo"  title=""  width="1134" height="171" data-lazy-src="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_MainLogo-copy-4.png" /><noscript><img class="tdb-logo-img td-retina-data" data-retina="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_RetinaMobile-Logo-copy-3.png" src="https://www.databasejournal.com/wp-content/uploads/2021/12/DBJ_logo_MainLogo-copy-4.png" alt="Logo"  title=""  width="1134" height="171" /></noscript></span></a></div></div> <!-- ./block --><div class="tdm_block td_block_wrap tdm_block_inline_text tdi_86 tdm-inline-block td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_86" >
<style>

/* inline tdc_css att */

.tdi_86{
width:80% !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_86{
width:100% !important;
justify-content:center !important;
text-align:center !important;
}
}

</style>
<style>
/* custom css */
.tdm_block.tdm_block_inline_text{
                  margin-bottom: 0;
                  vertical-align: top;
                }.tdm_block.tdm_block_inline_text .tdm-descr{
                  margin-bottom: 0;
                  -webkit-transform: translateZ(0);
                  transform: translateZ(0);
                }.tdc-row-content-vert-center .tdm-inline-text-yes{
                  vertical-align: middle;
                }.tdc-row-content-vert-bottom .tdm-inline-text-yes{
                  vertical-align: bottom;
                }.tdi_86{
                    text-align: left !important;
                }.tdi_86 .tdm-descr{
                    color: #ffffff;
                
					font-family:Varela !important;font-size:16px !important;line-height:1.4 !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_86 .tdm-descr{
					font-family:Varela !important;font-size:12px !important;line-height:1.4 !important;
				}
}

/* phone */
@media (max-width: 767px){
.tdi_86{
                    text-align: center !important;
                    margin-right: auto; 
                    margin-left: auto;
                }
}
</style><p class="tdm-descr">DatabaseJournal.com publishes relevant, up-to-date and pragmatic articles on the use of database hardware and management tools and serves as a forum for professional knowledge about proprietary, open source and cloud-based databases--foundational technology for all IT systems. We publish insightful articles about new products, best practices and trends; readers help each other out on various database questions and problems. Database management systems (DBMS) and database security processes are also key areas of focus at DatabaseJournal.com. </p></div><div class="tdm_block td_block_wrap tdm_block_socials tdi_87 tdm-inline-block tdm-content-horiz-left td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_87" >
<style>

/* inline tdc_css att */

.tdi_87{
margin-top:10px !important;
margin-bottom:20px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_87{
margin-right:auto !important;
margin-left:auto !important;
}
}

</style>
<style>
.tdi_88 .tdm-social-item i{
					font-size: 20px;
					vertical-align: middle;
				
					line-height: 36px;
				}.tdi_88 .tdm-social-item i.td-icon-twitter,
				.tdi_88 .tdm-social-item i.td-icon-linkedin,
				.tdi_88 .tdm-social-item i.td-icon-pinterest,
				.tdi_88 .tdm-social-item i.td-icon-blogger,
				.tdi_88 .tdm-social-item i.td-icon-vimeo{
					font-size: 16px;
				}.tdi_88 .tdm-social-item{
					width: 36px;
					height: 36px;
				
				    margin: 5px 10px 5px 0;
				}.tdi_88 .tdm-social-item-wrap:last-child .tdm-social-item{
				    margin-right: 0 !important;
				}.tdi_88 .tdm-social-item i,
				.tds-team-member2 .tdi_88.tds-social1 .tdm-social-item i{
					color: #ffffff;
				}.tdi_88 .tdm-social-item-wrap:hover i,
				.tds-team-member2 .tdi_88.tds-social1 .tdm-social-item:hover i{
					color: #67bb51;
				}.tdi_88 .tdm-social-text{
					display: none;
				
					margin-left: 2px;
				
					margin-right: 18px;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_88 .tdm-social-item i{
					font-size: 12px;
					vertical-align: middle;
				
					line-height: 21.6px;
				}.tdi_88 .tdm-social-item i.td-icon-twitter,
				.tdi_88 .tdm-social-item i.td-icon-linkedin,
				.tdi_88 .tdm-social-item i.td-icon-pinterest,
				.tdi_88 .tdm-social-item i.td-icon-blogger,
				.tdi_88 .tdm-social-item i.td-icon-vimeo{
					font-size: 9.6px;
				}.tdi_88 .tdm-social-item{
					width: 21.6px;
					height: 21.6px;
				}
}
</style><div class="tdm-social-wrapper tds-social1 tdi_88"><div class="tdm-social-item-wrap"><a href="https://www.facebook.com/DatabaseJournal/"  title="Facebook" class="tdm-social-item"><i class="td-icon-font td-icon-facebook"></i></a><a href="https://www.facebook.com/DatabaseJournal/" class="tdm-social-text" >Facebook</a></div><div class="tdm-social-item-wrap"><a href="https://www.linkedin.com/company/database-journal/about/"  title="Linkedin" class="tdm-social-item"><i class="td-icon-font td-icon-linkedin"></i></a><a href="https://www.linkedin.com/company/database-journal/about/" class="tdm-social-text" >Linkedin</a></div><div class="tdm-social-item-wrap"><a href="https://twitter.com/databasejournal"  title="Twitter" class="tdm-social-item"><i class="td-icon-font td-icon-twitter"></i></a><a href="https://twitter.com/databasejournal" class="tdm-social-text" >Twitter</a></div></div></div></div></div><div class="vc_column tdi_90  wpb_column vc_column_container tdc-column td-pb-span6">
<style scoped>

/* custom css */
.tdi_90{
                    vertical-align: baseline;
                }.tdi_90 > .wpb_wrapper,
				.tdi_90 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_90 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_90 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_90 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="vc_row_inner tdi_92  vc_row vc_inner wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_92{
                    position: relative !important;
                    top: 0;
                    transform: none;
                    -webkit-transform: none;
                }.tdi_92,
				.tdi_92 .tdc-inner-columns{
				    display: block;
				}.tdi_92 .tdc-inner-columns{
				    width: 100%;
				}
</style><div class="vc_column_inner tdi_94  wpb_column vc_column_container tdc-inner-column td-pb-span6">
<style scoped>

/* custom css */
.tdi_94{
                    vertical-align: baseline;
                }.tdi_94 .vc_column-inner > .wpb_wrapper,
				.tdi_94 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_94 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_94{
margin-bottom:0px !important;
padding-bottom:0px !important;
}
}

</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap td_block_title tdi_95 td-pb-border-top td_block_template_2 td-fix-index"  data-td-block-uid="tdi_95" >
<style>
.td-theme-wrap .tdi_95 .td-block-title > *,
            .td-theme-wrap .tdi_95 .td-pulldown-filter-link:hover,
            .td-theme-wrap .tdi_95 .td-subcat-item a:hover,
            .td-theme-wrap .tdi_95 .td-subcat-item .td-cur-simple-item,
            .td-theme-wrap .tdi_95 .td-subcat-dropdown:hover .td-subcat-more span,
            .td-theme-wrap .tdi_95 .td-subcat-dropdown:hover .td-subcat-more i {
                color: #67bb51;
            }

            .td-theme-wrap .tdi_95 .td-subcat-dropdown ul:after {
                background-color: #67bb51;
            }
            
            
            .td-theme-wrap .tdi_95 .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .tdi_95 .td_quote_on_blocks,
            .td-theme-wrap .tdi_95 .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .tdi_95 .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .tdi_95 .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .tdi_95 .td-instagram-user a {
                color: #67bb51;
            }

            .td-theme-wrap .tdi_95 .td-next-prev-wrap a:hover,
            .td-theme-wrap .tdi_95 .td-load-more-wrap a:hover {
                background-color: #67bb51;
                border-color: #67bb51;
            }

            .td-theme-wrap .tdi_95 .td-read-more a,
            .td-theme-wrap .tdi_95 .td-weather-information:before,
            .td-theme-wrap .tdi_95 .td-weather-week:before,
            .td-theme-wrap .tdi_95 .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .tdi_95 .td-post-category,
            .td-theme-wrap .tdi_95 .td-post-category:hover {
                background-color: #67bb51;
            }
/* inline tdc_css att */

.tdi_95{
margin-bottom:-5px !important;
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_95{
margin-bottom:-15px !important;
}
}

/* phone */
@media (max-width: 767px)
{
.tdi_95{
width:100% !important;
display:inline-block !important;
}
}

</style>
<style>
/* custom css */
body .tdi_95 .td-block-title a,
				body .tdi_95 .td-block-title span{
					font-family:Montserrat !important;font-size:24px !important;font-weight:600 !important;letter-spacing:1px !important;
				}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
body .tdi_95 .td-block-title a,
				body .tdi_95 .td-block-title span{
					font-family:Montserrat !important;font-size:19px !important;font-weight:600 !important;letter-spacing:1px !important;
				}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
body .tdi_95 .td-block-title a,
				body .tdi_95 .td-block-title span{
					font-family:Montserrat !important;font-size:18px !important;font-weight:600 !important;letter-spacing:1px !important;
				}
}

/* phone */
@media (max-width: 767px){
body .tdi_95 .td-block-title{
					text-align: center;
				}body .tdi_95.td_block_template_4 .td-block-title > *:before,
				body .tdi_95.td_block_template_17 .td-block-title:after,
				body .tdi_95.td_block_template_13 .td-block-subtitle,
				body .tdi_95.td_block_template_9 .td-block-title:after{
				    right: 0;
				    left: 0;
				}body .tdi_95.td_block_template_5 .td-block-title > *{
				    border-width: 0 0 0 4px;
				}body .tdi_95.td_block_template_8 .td-block-title > *{
					padding-left: 20px;
					padding-right: 20px;
				}
}
</style><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Advertisers</span></h4></div></div><div class="tdm_block td_block_wrap tdm_block_inline_text tdi_96 tdm-inline-block td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_96" >
<style>

/* inline tdc_css att */

.tdi_96{
margin-bottom:30px !important;
width:80% !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_96{
width:100% !important;
justify-content:center !important;
text-align:center !important;
}
}

</style>
<style>
/* custom css */
.tdi_96{
                    text-align: left !important;
                }.tdi_96 .tdm-descr{
                    color: #ffffff;
                
					font-family:Varela !important;font-size:16px !important;line-height:1.4 !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_96 .tdm-descr{
					font-family:Varela !important;font-size:12px !important;line-height:1.4 !important;
				}
}

/* phone */
@media (max-width: 767px){
.tdi_96{
                    text-align: center !important;
                    margin-right: auto; 
                    margin-left: auto;
                }
}
</style><p class="tdm-descr">Advertise with TechnologyAdvice on Database Journal and our other IT-focused platforms.</p></div><div class="tdm_block td_block_wrap tdm_block_button tdi_97 tdm-block-button-inline tdm-content-horiz-center td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_97"     >
<style>

/* inline tdc_css att */

.tdi_97{
border-color:#67bb51 !important;
border-style:solid !important;
border-width:0 !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_97{
width:100% !important;
}
}

</style>
<style>
/* custom css */
.tdm_block.tdm_block_button{
                  margin-bottom: 0;
                }.tdm_block.tdm_block_button .tds-button{
                  line-height: 0;
                }.tdm_block.tdm_block_button.tdm-block-button-inline{
                  display: inline-block;
                }.tdm_block.tdm_block_button.tdm-block-button-full,
                .tdm_block.tdm_block_button.tdm-block-button-full .tdm-btn{
                  display: block;
                }.tdi_97 .tdm-btn{
                    height: auto;
                    padding: 10px;
                }

/* phone */
@media (max-width: 767px){
.tdi_97 .tdm-btn{
                    height: auto;
                    padding: 15px 30px;
                }
}
</style>
<style>
body .tdi_98{
					background-color: #67bb51;
				}.tdi_98{
                    padding: 10px;
                    height: auto;
                    line-height: 1;
                
					font-weight:500 !important;
				}.tdi_98 .tdm-btn-icon:last-child{
					margin-left: 10px;
				}.tdi_98,
				.tdi_98:before{
					border-radius: 15px;
				}

/* phone */
@media (max-width: 767px){
.tdi_98{
                    padding: 15px 30px;
                    height: auto;
                    line-height: 1;
                }.tdi_98,
				.tdi_98:before{
					border-radius: 25px;
				}
}
</style><div class="tds-button td-fix-index"><a 
                href="https://solutions.technologyadvice.com/advertise-on-database-journal/?utm_source=databasejournal&amp;utm_medium=portfolio_footer&amp;utm_campaign=advertise_button" 
                class="tds-button1 tdm-btn tdm-btn-lg tdi_98" ><span class="tdm-btn-text">Advertise with Us</span><i class="tdm-btn-icon tdc-font-fa tdc-font-fa-angle-right"></i></a></div></div></div></div></div><div class="vc_column_inner tdi_100  wpb_column vc_column_container tdc-inner-column td-pb-span6">
<style scoped>

/* custom css */
.tdi_100{
                    vertical-align: baseline;
                }.tdi_100 .vc_column-inner > .wpb_wrapper,
				.tdi_100 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_100 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_100{
display:none !important;
}
}

</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap td_block_title tdi_101 td-pb-border-top td_block_template_2 td-fix-index"  data-td-block-uid="tdi_101" >
<style>
.td-theme-wrap .tdi_101 .td-block-title > *,
            .td-theme-wrap .tdi_101 .td-pulldown-filter-link:hover,
            .td-theme-wrap .tdi_101 .td-subcat-item a:hover,
            .td-theme-wrap .tdi_101 .td-subcat-item .td-cur-simple-item,
            .td-theme-wrap .tdi_101 .td-subcat-dropdown:hover .td-subcat-more span,
            .td-theme-wrap .tdi_101 .td-subcat-dropdown:hover .td-subcat-more i {
                color: #67bb51;
            }

            .td-theme-wrap .tdi_101 .td-subcat-dropdown ul:after {
                background-color: #67bb51;
            }
            
            
            .td-theme-wrap .tdi_101 .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .tdi_101 .td_quote_on_blocks,
            .td-theme-wrap .tdi_101 .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .tdi_101 .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .tdi_101 .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .tdi_101 .td-instagram-user a {
                color: #67bb51;
            }

            .td-theme-wrap .tdi_101 .td-next-prev-wrap a:hover,
            .td-theme-wrap .tdi_101 .td-load-more-wrap a:hover {
                background-color: #67bb51;
                border-color: #67bb51;
            }

            .td-theme-wrap .tdi_101 .td-read-more a,
            .td-theme-wrap .tdi_101 .td-weather-information:before,
            .td-theme-wrap .tdi_101 .td-weather-week:before,
            .td-theme-wrap .tdi_101 .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .tdi_101 .td-post-category,
            .td-theme-wrap .tdi_101 .td-post-category:hover {
                background-color: #67bb51;
            }
/* inline tdc_css att */

.tdi_101{
margin-bottom:-5px !important;
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_101{
margin-bottom:-15px !important;
}
}

/* phone */
@media (max-width: 767px)
{
.tdi_101{
display:inline-block !important;
}
}

</style>
<style>
/* custom css */
body .tdi_101 .td-block-title a,
				body .tdi_101 .td-block-title span{
					font-family:Montserrat !important;font-size:24px !important;font-weight:600 !important;letter-spacing:1px !important;
				}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
body .tdi_101 .td-block-title a,
				body .tdi_101 .td-block-title span{
					font-family:Montserrat !important;font-size:19px !important;font-weight:600 !important;letter-spacing:1px !important;
				}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
body .tdi_101 .td-block-title a,
				body .tdi_101 .td-block-title span{
					font-family:Montserrat !important;font-size:18px !important;font-weight:600 !important;letter-spacing:1px !important;
				}
}
</style><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Menu</span></h4></div></div><div class="td_block_wrap td_block_list_menu tdi_102 td-pb-border-top td_block_template_2 widget"  data-td-block-uid="tdi_102" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_102{
justify-content:center !important;
text-align:center !important;
}
}

</style>
<style>
/* custom css */
.td_block_list_menu ul{
                  flex-wrap: wrap;
                  margin-left: 12px;
                }.td_block_list_menu ul li{
                  margin-left: 0;
                }.td_block_list_menu .sub-menu{
                  padding-left: 22px;
                }.td_block_list_menu .sub-menu li{
                  font-size: 13px;
                }.tdi_102 ul{
					margin: 0px;
				
					text-align: left;
					justify-content: flex-start;
				}.tdi_102 a{
					color: #ffffff;
				}.tdi_102 a:hover{
					color: #67bb51;
				}.tdi_102 .td-block-title a,
				.tdi_102 .td-block-title span{
					font-family:Open Sans !important;font-size:14px !important;font-weight:500 !important;
				}.tdi_102 li{
					font-family:Varela !important;font-size:16px !important;line-height:24px !important;letter-spacing:1px !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_102 li{
					font-family:Varela !important;font-size:16px !important;line-height:20px !important;letter-spacing:1px !important;
				}
}
</style><div class="td-block-title-wrap"></div><div id=tdi_102 class="td_block_inner td-fix-index"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-107"><a href="https://www.databasejournal.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-108"><a href="https://technologyadvice.com/terms-conditions/">Terms</a></li>
<li id="menu-item-109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-109"><a href="https://technologyadvice.com/about-us/">About</a></li>
<li id="menu-item-110" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110"><a href="https://technologyadvice.com/contact-us/">Contact</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111"><a href="https://solutions.technologyadvice.com/advertise-on-database-journal/?utm_source=databasejournal&#038;utm_medium=portfolio_footer&#038;utm_campaign=advertise_contact-us">Advertise</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112"><a href="https://technologyadvice.com/privacy-policy/ccpa-opt-out-form/">California &#8211; Do Not Sell My Information</a></li>
</ul></div></div></div></div></div></div></div></div></div></div></div><div id="tdi_103" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_104  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_104,
                .tdi_104 .tdc-columns{
                    min-height: 0;
                }.tdi_104,
				.tdi_104 .tdc-columns{
				    display: block;
				}.tdi_104 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_106  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_106{
                    vertical-align: baseline;
                }.tdi_106 > .wpb_wrapper,
				.tdi_106 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_106 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_106 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_106 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_separator td_block_wrap vc_separator tdi_108  td_separator_solid td_separator_center"><span style="border-color:#EBEBEB;border-width:1px;width:100%;"></span>
<style scoped>

/* custom css */
.td_block_separator{
                  width: 100%;
                  align-items: center;
                  margin-bottom: 38px;
                  padding-bottom: 10px;
                }.td_block_separator span{
                  position: relative;
                  display: block;
                  margin: 0 auto;
                  width: 100%;
                  height: 1px;
                  border-top: 1px solid #EBEBEB;
                }.td_separator_align_left span{
                  margin-left: 0;
                }.td_separator_align_right span{
                  margin-right: 0;
                }.td_separator_dashed span{
                  border-top-style: dashed;
                }.td_separator_dotted span{
                  border-top-style: dotted;
                }.td_separator_double span{
                  height: 3px;
                  border-bottom: 1px solid #EBEBEB;
                }.td_separator_shadow > span{
                  position: relative;
                  height: 20px;
                  overflow: hidden;
                  border: 0;
                  color: #EBEBEB;
                }.td_separator_shadow > span > span{
                  position: absolute;
                  top: -30px;
                  left: 0;
                  right: 0;
                  margin: 0 auto;
                  height: 13px;
                  width: 98%;
                  border-radius: 100%;
                }
/* inline tdc_css att */

.tdi_108{
margin-top:15px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_108{
margin-top:50px !important;
}
}

</style></div><div class="tdm_block td_block_wrap tdm_block_column_title tdi_109 tdm-content-horiz-center td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_109" >
<style>
/* custom css */
.tdm_block_column_title{
                  margin-bottom: 0;
                  display: inline-block;
                  width: 100%;
                }
</style><div class="td-block-row"><div class="td-block-span12 tdm-col">
<style>
body .tdi_110 .tdm-title{
					background-color: #ffffff;
					-webkit-background-clip: text;
					-webkit-text-fill-color: transparent;
				}html[class*='ie'] .tdi_110 .tdm-title{
				    background: none;
					color: #ffffff;
				}body .tdi_109:hover .tdi_110 .tdm-title{
					color: #ffffff;
				
					-webkit-text-fill-color: unset;
					background: transparent;
					transition: none;
				}.tdi_109:hover .tdi_110 .tdm-title{
					cursor: default;
				}.tdi_110 .tdm-title{
					font-family:Montserrat !important;font-weight:600 !important;
				}
</style><div class="tds-title tds-title1 td-fix-index tdi_110"><h3 class="tdm-title tdm-title-md">Our Brands</h3></div></div></div></div></div></div></div></div><div id="tdi_111" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_112  wpb_row td-pb-row tdc-row-content-vert-center" >
<style scoped>

/* custom css */
.tdi_112,
                .tdi_112 .tdc-columns{
                    min-height: 0;
                }.tdi_112,
				.tdi_112 .tdc-columns{
				    display: block;
				}.tdi_112 .tdc-columns{
				    width: 100%;
				}@media (min-width: 768px) {
	                .tdi_112 {
	                    margin-left: -2px;
	                    margin-right: -2px;
	                }
	                .tdi_112 .tdc-row-video-background-error,
	                .tdi_112 .vc_column {
	                    padding-left: 2px;
	                    padding-right: 2px;
	                }
                }@media (min-width: 767px) {
                    .tdi_112.tdc-row-content-vert-center,
                    .tdi_112.tdc-row-content-vert-center .tdc-columns {
                        display: flex;
                        align-items: center;
                        flex: 1;
                    }
                    .tdi_112.tdc-row-content-vert-bottom,
                    .tdi_112.tdc-row-content-vert-bottom .tdc-columns {
                        display: flex;
                        align-items: flex-end;
                        flex: 1;
                    }
                    .tdi_112.tdc-row-content-vert-center .td_block_wrap {
                        vertical-align: middle;
                    }
                    .tdi_112.tdc-row-content-vert-bottom .td_block_wrap {
                        vertical-align: bottom;
                    }
                }
</style><div class="vc_column tdi_114  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_114{
                    vertical-align: baseline;
                }.tdi_114 > .wpb_wrapper,
				.tdi_114 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_114 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_114 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_114 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_115  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_115"><a data-bg="https://www.databasejournal.com/wp-content/uploads/2021/01/TAwhitefooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://technologyadvice.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_115{
margin-right:auto !important;
margin-left:auto !important;
}
}

</style>
<style>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</style></div><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_116  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_116"><a data-bg="https://www.databasejournal.com/wp-content/uploads/2021/01/eweekfooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.eweek.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_116{
margin-right:auto !important;
margin-left:auto !important;
}
}

</style>
<style>
/* custom css */
.tdi_116 .td_single_image_bg{
					height: 40px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_116{
					width: 100%;
				}.tdi_116:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div></div></div><div class="vc_column tdi_118  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_118{
                    vertical-align: baseline;
                }.tdi_118 > .wpb_wrapper,
				.tdi_118 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_118 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_118 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_118 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_119  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_119"><a data-bg="https://www.databasejournal.com/wp-content/uploads/2021/01/datamationwhitefooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.datamation.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_119{
margin-right:auto !important;
margin-left:auto !important;
}
}

</style>
<style>
/* custom css */
.tdi_119 .td_single_image_bg{
					height: 40px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_119{
					width: 100%;
				}.tdi_119:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_120  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_120"><a data-bg="https://www.databasejournal.com/wp-content/uploads/2021/01/PMcomwhitefooter-09.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://project-management.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_120{
margin-right:auto !important;
margin-left:auto !important;
}
}

</style>
<style>
/* custom css */
.tdi_120 .td_single_image_bg{
					height: 45px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_120{
					width: 100%;
				}.tdi_120:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div></div></div><div class="vc_column tdi_122  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_122{
                    vertical-align: baseline;
                }.tdi_122 > .wpb_wrapper,
				.tdi_122 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_122 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_122 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_122 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_123  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_123"><a data-bg="https://www.databasejournal.com/wp-content/uploads/2021/01/webowhitefooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.webopedia.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_123{
margin-right:auto !important;
margin-left:auto !important;
}
}

</style>
<style>
/* custom css */
.tdi_123 .td_single_image_bg{
					height: 35px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_123{
					width: 100%;
				
					display: inline-block;
				}.tdi_123:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_124  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_124"><a data-bg="https://www.databasejournal.com/wp-content/uploads/2021/01/esecuritywhitefooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.esecurityplanet.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_124{
margin-right:auto !important;
margin-left:auto !important;
}
}

</style>
<style>
/* custom css */
.tdi_124 .td_single_image_bg{
					height: 45px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_124{
					width: 100%;
				}.tdi_124:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div></div></div><div class="vc_column tdi_126  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_126{
                    vertical-align: baseline;
                }.tdi_126 > .wpb_wrapper,
				.tdi_126 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_126 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_126 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_126 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_127  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_127"><a data-bg="https://www.databasejournal.com/wp-content/uploads/2021/01/serverwatchwhitefooter-10.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.serverwatch.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_127{
margin-right:auto !important;
margin-left:auto !important;
}
}

</style>
<style>
/* custom css */
.tdi_127 .td_single_image_bg{
					height: 50px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_127{
					width: 100%;
				}.tdi_127:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_128  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_128"><a data-bg="https://www.databasejournal.com/wp-content/uploads/2021/01/ITBEwhitefooter-copy.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.itbusinessedge.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_128{
margin-right:auto !important;
margin-left:auto !important;
}
}

</style>
<style>
/* custom css */
.tdi_128 .td_single_image_bg{
					height: 45px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_128{
					width: 100%;
				
					display: inline-block;
				}.tdi_128:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div></div></div></div></div><div id="tdi_129" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_130  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_130,
                .tdi_130 .tdc-columns{
                    min-height: 0;
                }.tdi_130,
				.tdi_130 .tdc-columns{
				    display: block;
				}.tdi_130 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_132  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_132{
                    vertical-align: baseline;
                }.tdi_132 > .wpb_wrapper,
				.tdi_132 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_132 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_132 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_132 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_separator td_block_wrap vc_separator tdi_134  td_separator_solid td_separator_center"><span style="border-color:#EBEBEB;border-width:1px;width:100%;"></span>
<style scoped>

/* inline tdc_css att */

.tdi_134{
margin-top:15px !important;
}

</style></div><div class="vc_row_inner tdi_136  vc_row vc_inner wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_136{
                    position: relative !important;
                    top: 0;
                    transform: none;
                    -webkit-transform: none;
                }.tdi_136,
				.tdi_136 .tdc-inner-columns{
				    display: block;
				}.tdi_136 .tdc-inner-columns{
				    width: 100%;
				}
</style><div class="vc_column_inner tdi_138  wpb_column vc_column_container tdc-inner-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_138{
                    vertical-align: baseline;
                }.tdi_138 .vc_column-inner > .wpb_wrapper,
				.tdi_138 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_138 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_menu tdi_139 tds_menu_active1 tds_menu_sub_active1 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_139"  style=" z-index: 999;">
<style>
/* custom css */
.tdi_139 .td_block_inner{
                    text-align: center;
                }.tdi_139 .tdb-menu > li .tdb-menu-sep,
                .tdi_139 .tdb-menu-items-dropdown .tdb-menu-sep{
                    top: -1px;
                }.tdi_139 .tdb-menu > li > a .tdb-sub-menu-icon,
                .tdi_139 .td-subcat-more .tdb-menu-more-subicon{
                    top: -1px;
                }.tdi_139 .td-subcat-more .tdb-menu-more-icon{
                    top: 0px;
                }.tdi_139 .tdb-menu > li > a,
                .tdi_139 .td-subcat-more{
                    color: #ffffff;
                }.tdi_139 .tdb-menu > li > a .tdb-sub-menu-icon-svg svg,
                .tdi_139 .tdb-menu > li > a .tdb-sub-menu-icon-svg svg *,
                .tdi_139 .td-subcat-more .tdb-menu-more-subicon-svg svg,
                .tdi_139 .td-subcat-more .tdb-menu-more-subicon-svg svg *,
                .tdi_139 .td-subcat-more .tdb-menu-more-icon-svg,
                .tdi_139 .td-subcat-more .tdb-menu-more-icon-svg *{
                    fill: #ffffff;
                }.tdi_139 .tdb-menu > li > a,
                .tdi_139 .td-subcat-more,
                .tdi_139 .td-subcat-more > .tdb-menu-item-text{
                    font-family:Montserrat !important;font-size:14px !important;
                }.tdi_139 .tdb-normal-menu ul .tdb-menu-item > a .tdb-sub-menu-icon,
                .tdi_139 .td-pulldown-filter-list .tdb-menu-item > a .tdb-sub-menu-icon{
                    right: 0;
                
                    margin-top: 1px;
                }.tdi_139 .tdb-menu .tdb-normal-menu ul,
                .tdi_139 .td-pulldown-filter-list,
                .tdi_139 .td-pulldown-filter-list .sub-menu{
                    box-shadow:  1px 1px 4px 0px rgba(0, 0, 0, 0.15);
                }.tdi_139 .tdb-menu .tdb-mega-menu .sub-menu > li{
					box-shadow:  0px 2px 6px 0px rgba(0, 0, 0, 0.1);
				}

/* phone */
@media (max-width: 767px){
.tdi_139 .tdb-menu > li > a,
                .tdi_139 .td-subcat-more,
                .tdi_139 .td-subcat-more > .tdb-menu-item-text{
                    font-family:Montserrat !important;font-size:10px !important;
                }
}
</style>
<style>
.tdi_139 .tdb-menu > li > a:after,
				.tdi_139 .tdb-menu-items-dropdown .td-subcat-more:after{
					background-color: #67bb51;
				
					bottom: 0px;
				}
</style>
<style>

</style><div id=tdi_139 class="td_block_inner td-fix-index"><div class="tdb-main-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-down tdb-main-sub-menu-icon"></i></div><div class="tdb-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-right-arrow"></i></div><ul id="menu-footer-menu-1" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-107"><a href="https://www.databasejournal.com/privacy-policy/"><div class="tdb-menu-item-text">Privacy Policy</div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-108"><a href="https://technologyadvice.com/terms-conditions/"><div class="tdb-menu-item-text">Terms</div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-109"><a href="https://technologyadvice.com/about-us/"><div class="tdb-menu-item-text">About</div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-110"><a href="https://technologyadvice.com/contact-us/"><div class="tdb-menu-item-text">Contact</div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-111"><a href="https://solutions.technologyadvice.com/advertise-on-database-journal/?utm_source=databasejournal&#038;utm_medium=portfolio_footer&#038;utm_campaign=advertise_contact-us"><div class="tdb-menu-item-text">Advertise</div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-112"><a href="https://technologyadvice.com/privacy-policy/ccpa-opt-out-form/"><div class="tdb-menu-item-text">California &#8211; Do Not Sell My Information</div></a></li>
</ul></div></div></div></div></div></div><div class="tdm_block td_block_wrap tdm_block_column_content tdi_142 tdm-content-horiz-center td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_142" >
<style>

/* inline tdc_css att */

.tdi_142{
margin-top:20px !important;
}

</style>
<style>
/* custom css */
.tdm_block_column_content .tdm-image-holder{
                  position: relative;
                  display: block;
                  height: 0;
                  margin-bottom: 24px;
                  padding-bottom: 70%;
                }.tdm_block_column_content .tdm-image-holder:hover .tdm-hover-img{
                  opacity: 1;
                }.tdm_block_column_content .tdm-image-holder > div{
                  position: absolute;
                  top: 0;
                  left: 0;
                  width: 100%;
                  height: 100%;
                  background-repeat: no-repeat;
                  background-position: center center;
                  background-size: cover;
                }.tdm_block_column_content .tdm-hover-img{
                  opacity: 0;
                  -webkit-transition: all 0.4s ease-in-out;
                  transition: all 0.4s ease-in-out;
                }.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title{
                  color: #4db2ec;
                }.tdm_block_column_content .tdm-title-xxsm,
                .tdm_block_column_content .tdm-title-xsm{
                  margin-bottom: 20px;
                }.tdm_block_column_content .tdm-title-md{
                  margin-bottom: 14px;
                }.tdm_block_column_content .tdm-title-bg{
                  margin-bottom: 16px;
                }.tdm_block_column_content .tdm-descr{
                  margin-bottom: 0;
                }.tdm_block_column_content .tds-button{
                  margin-top: 25px;
                }.tdi_142 .tdm-descr{
                    color: #ffffff;
                
					font-size:11px !important;line-height:1.2 !important;
				}@media (max-width: 767px) {
                  .tdm_block_column_content .tdm-image-holder {
                    margin-bottom: 14px;
                  }
                }
</style><div class="tdm-col-content-info"><a href="#" target="_blank"  class="tdm-col-content-title-url"></a><p class="tdm-descr td-fix-index">Property of TechnologyAdvice.<br>
&copy; 2022 TechnologyAdvice. All Rights Reserved<br><br>
Advertiser Disclosure: Some of the products that appear on this site are from companies from which TechnologyAdvice receives compensation. This compensation may impact how and where products appear on this site including, for example, the order in which they appear. TechnologyAdvice does not include all companies or all types of products available in the marketplace.</p></div></div><div class="wpb_wrapper td_block_empty_space td_block_wrap vc_empty_space tdi_144 "  style="height: 60px"></div></div></div></div></div><div id="tdi_145" class="tdc-row"><div class="vc_row tdi_146  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_146,
                .tdi_146 .tdc-columns{
                    min-height: 0;
                }.tdi_146,
				.tdi_146 .tdc-columns{
				    display: block;
				}.tdi_146 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_148  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_148{
                    vertical-align: baseline;
                }.tdi_148 > .wpb_wrapper,
				.tdi_148 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_148 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_148 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_148 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_wrap vc_raw_html tdi_150 choice-footer-msg">
<style scoped>

/* inline tdc_css att */

.tdi_150{
margin-top:0px !important;
margin-bottom:10px !important;
padding-top:0px !important;
border-style:solid !important;
border-color:#888888 !important;
border-width: 0px 0px 0px 0px !important;
}

</style><div class="td-fix-index"><div id="choice-footer-msg" style="color:#ffffff;">
</div></div></div></div></div></div></div></div></div>        </div>

    </div>
    
</div><!--close td-outer-wrap-->


<script>(function(){var advanced_ads_ga_UID="UA-48210401-1",advanced_ads_ga_anonymIP=!!1;function AdvAdsAdBlockCounterGA(t){this.UID=t,this.analyticsObject="function"==typeof gtag;var n=this;return this.count=function(){gtag("event","AdBlock",{event_category:"Advanced Ads",event_label:"Yes",non_interaction:!0,send_to:n.UID})},function(){if(!n.analyticsObject){var e=document.createElement("script");e.src="https://www.googletagmanager.com/gtag/js?id="+t,e.async=!0,document.body.appendChild(e),window.dataLayer=window.dataLayer||[],window.gtag=function(){dataLayer.push(arguments)},n.analyticsObject=!0,gtag("js",new Date)}var a={send_page_view:!1,transport_type:"beacon"};window.advanced_ads_ga_anonymIP&&(a.anonymize_ip=!0),gtag("config",t,a)}(),this}window.advanced_ads_check_adblocker=function(t){var n=[],e=null;function a(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}return a((function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),a((function(){var a=window.getComputedStyle&&window.getComputedStyle(t),o=a&&a.getPropertyValue("-moz-binding");e=a&&"none"===a.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0,d=n.length;i<d;i++)n[i](e);n=[]}))})),function(t){null!==e?t(e):n.push(t)}}(),advanced_ads_check_adblocker((function(t){t&&new AdvAdsAdBlockCounterGA(advanced_ads_ga_UID).count()}));})();</script><div class="wp-ads-sticky-footer wp-ads-sticky wp-ads-target" id="wp-ads-1564235086" style="position: fixed; bottom: 0; z-index: 10000; " data-advadstrackid="120" data-advadstrackbid="1"><span class="wp-ads-close-button" onclick="void(0)" title="close" style="width: 15px; height: 15px; background: #fff; position: relative; line-height: 15px; text-align: center; cursor: pointer; z-index: 10000;right:-15px;float: right; margin-left: -15px;">×</span><!-- Start: GAM Ad Slot Render | DBJ Sticky Bottom -->
<div id="sticky-bottom" style="max-width: 1020px; min-width: 300px; width: auto; text-align:center; min-height: 50px; max-height: 90px; height: auto; background-color: #ffffff; border:1px solid #efefef;">
    <script>
        window.googletag = window.googletag ||
        {
            cmd: []
        };

        window.googletag.cmd.push(function()
        {
            googletag.display("sticky-bottom");
        });
    </script>
</div>
<!-- End: GAM Ad Slot Render | DBJ Sticky Bottom --></div><script>( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {var wrapper_id = "#wp-ads-1564235086"; var $wrapper = jQuery( wrapper_id );advads.move( wrapper_id, "", {  });window.advanced_ads_sticky_items = window.advanced_ads_sticky_items || {};advanced_ads_sticky_items[ "wp-ads-1564235086" ] = { "can_convert_to_abs": "1", "initial_css": $wrapper.attr( "style" ), "modifying_func": function() { $wrapper.css({ "-webkit-transform": "translateX(-50%)", "-moz-transform": "translateX(-50%)", "transform": "translateX(-50%)", "left": "50%", "margin-right": "-50%" });jQuery( "#wp-ads-1564235086" ).on( "click", "span", function() { advads.close( "#wp-ads-1564235086" ); });}};
if ( advads.wait_for_images ) { 
    var sticky_wait_for_images_time = new Date().getTime();
    $wrapper.data( "sticky_wait_for_images_time", sticky_wait_for_images_time );
    advads.wait_for_images( $wrapper, function() {
        // At the moment when this function is called, it is possible that 
        // the placement has been updated using "Reload ads on resize" feature of Responsive add-on 
        if ( $wrapper.data( "sticky_wait_for_images_time" ) === sticky_wait_for_images_time ) {
            advanced_ads_sticky_items[ "wp-ads-1564235086" ]["modifying_func"]();
        } 
    } );
} else { 
    advanced_ads_sticky_items[ "wp-ads-1564235086" ]["modifying_func"]();
};
});</script>

    <!--

        Theme: Newspaper by tagDiv.com 2022
        Version: 11.4.3 (rara)
        Deploy mode: deploy
        
        uid: 62caca6126963
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
/* GG: Fixes for mobile search thumbs */
.td-aj-search-results > .td_module_wrap > .td-module-container > .td-image-container
{
    display: none !important;
}
</style>

		<!-- Google Tag Manager (noscript) snippet added by Site Kit -->
		<noscript>
			<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PSKJD7X" height="0" width="0" style="display:none;visibility:hidden"></iframe>
		</noscript>
		<!-- End Google Tag Manager (noscript) snippet added by Site Kit -->
		<script data-minify="1" type='text/javascript' src='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/ta-intentclicks-master/includes/js/scripts.js?ver=1652717031' id='icp_js-js' defer></script>
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/www.databasejournal.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"64fe80d2da","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.15' id='ppress-frontend-script-js' defer></script>
<script type='text/javascript' id='advanced-ads-layer-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_layer_settings = {"layer_class":"wp-ads-layer","placements":[]};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1652717031' id='advanced-ads-layer-footer-js-js' defer></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1652717031' id='advanced-ads-responsive-js' defer></script>
<script type='text/javascript' id='advanced-ads-sticky-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_sticky_settings = {"check_position_fixed":"1","sticky_class":"wp-ads-sticky","placements":["sticky-footer"]};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.databasejournal.com/wp-content/cache/min/1/wp-content/plugins/advanced-ads-sticky-ads/public/assets/js/sticky.js?ver=1652717031' id='advanced-ads-sticky-footer-js-js' defer></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/www.databasejournal.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.17.2' id='advanced-ads-pro/front-js' defer></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/themes/src/custom.js?ver=5.9.3' id='custom-js-js' defer></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js' defer></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=b2e02a383c117d2c27b181e37c1c9e0e' id='tdb_js_posts_autoload-js' defer></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.4.3' id='td-site-min-js' defer></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js' defer></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"wp-ads-target","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.3.1' id='advadsTrackingScript-js' defer></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/delayed.min.js?ver=2.3.1' id='advadsTrackingDelayed-js' defer></script>
<script type='text/javascript' src='https://www.databasejournal.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=b2e02a383c117d2c27b181e37c1c9e0e' id='tdb_js_files_for_front-js' defer></script>
<!--noptimize--><script>window.advads_admin_bar_items = [{"title":"Datalayer &amp; GAM Core","type":"ad"},{"title":"Before Closing Head Tag","type":"placement"},{"title":"DBJ | MySQL \u2013 Ad Slot Definitions","type":"ad"},{"title":"MySQL | Ad Slot Definitions Placement","type":"placement"},{"title":"DBJ | Inline Top Render","type":"ad"},{"title":"Inline Top","type":"placement"},{"title":"DBJ | Sticky Rail Render","type":"ad"},{"title":"Sticky Rail","type":"placement"},{"title":"DBJ | Sticky Bottom Render","type":"ad"},{"title":"Sticky Footer","type":"placement"}];</script><!--/noptimize--><!--noptimize--><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><!--/noptimize-->
<!-- JS generated by theme -->

<script>
    

            
                /* global jQuery:{} */
                jQuery().ready(function () {

                    var tdbMenuItem = new tdbMenu.item();
                    tdbMenuItem.blockUid = 'tdi_36';
                    tdbMenuItem.jqueryObj = jQuery('.tdi_36');

	                
                    tdbMenuItem.isMegaMenuFull = true;

	                
	                
	                
                    tdbMenu.addItem(tdbMenuItem);

                });
            
            

            
                /* global jQuery:{} */
                jQuery().ready(function () {

                    var tdbMenuItem = new tdbMenu.item();
                    tdbMenuItem.blockUid = 'tdi_139';
                    tdbMenuItem.jqueryObj = jQuery('.tdi_139');

	                
	                
                    tdbMenuItem.isMegaMenuParentPos = true;

	                
	                
                    tdbMenu.addItem(tdbMenuItem);

                });
            
            
</script>

<script id="wp-ads-tracking">var advads_tracking_ads = {"1":[117,16606,119,121,120]};var advads_tracking_urls = {"1":"https:\/\/www.databasejournal.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"onrequest"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/www.databasejournal.com\/linkout\/"};</script><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.databasejournal.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<button class="play" aria-label="play Youtube video"></button>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.parentNode.dataset.query.length?'':'&'+this.parentNode.dataset.query;e.setAttribute("src",t.replace("ID",this.parentNode.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.parentNode.replaceChild(e,this.parentNode)}document.addEventListener("DOMContentLoaded",function(){var e,t,p,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),a[t].appendChild(e),p=e.querySelector('.play'),p.onclick=lazyLoadYoutubeIframe});</script>
</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->